struts-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "krishnan.1000" <krishnan.1...@gmail.com>
Subject Help: Getting Error Message "Not able to load configuration for specified action"
Date Thu, 04 Sep 2008 18:30:18 GMT

I am a Struts 2 newbie and I am trying to develop a simple web application.
The application consists of a simple login page containing a text field and
password field and submit button.

When I try to load the web page, this is the error tht I get. I am deploying
the application using Tomcat v6.

The requested resource (/turorial/login) is not available.

web.xml

    <webapp><filter>
        <filter-name>struts2</filter-name>
       
<filter-class>org.apache.struts2.dispatcher.FilterDispatcher</filter-class>
        <init-param>
            <param-name>actionPackages</param-name>
            <param-value>com.jbe.tutorial.web.action</param-value>
      </init-param>
      </filter>
     
      <filter-mapping>
        <filter-name>struts2</filter-name>
        <url-pattern>/*</url-pattern>
      </filter-mapping></webapp>



My struts.xml file

      <struts>
        <package name="tutorial" extends="struts-default" namespace="/">
    	   <action name="home">
    	     <result>/jsp/login.jsp</result>
    	   </action>
            <action name="login"
class="com.jbe.tutorial.web.action.LoginAction" method="login" >
               <result name="input">/jsp/login.jsp</result>
                <result name="success" type="redirect">loginSuccess</result>
            </action>
            
            <action name = "loginSuccess"
class="com.jbe.tutorial.web.action.LoginAction" method = "loginSuccess">
              <result name="success">/jsp/success.jsp</result>
            </action>
        </package>
    </struts>  



My login.jsp file

    <s:form action="login">
    <s:textfield name="username" label="Name"/>
    <s  assword name ="password" label="Password" />
    <input type="submit" name="Login" value="Login" />
    <input type="reset" value="Reset" name="reset" />
    </s:form>    



I am getting the error message No configuration found for the specified
action": 'login' in namespace ''. Form action defaulting to 'action'
attribute's literal value.

Is there anything I am doing wrong?  I have read similar posts in the forum
and have done all that has been suggested but I still am not getting the
error. Any help would be appreciated

Thanks,

Karthik Krishnan
-- 
View this message in context: http://www.nabble.com/Help%3A-Getting-Error-Message-%22Not-able-to-load-configuration-for-specified-action%22-tp19317093p19317093.html
Sent from the Struts - User mailing list archive at Nabble.com.


---------------------------------------------------------------------
To unsubscribe, e-mail: user-unsubscribe@struts.apache.org
For additional commands, e-mail: user-help@struts.apache.org


Mime
View raw message