struts-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Roger <roger.var...@googlemail.com>
Subject Re: Model Driven Tutorial/Howto
Date Tue, 02 Sep 2008 14:03:52 GMT
On Tuesday 02 September 2008 16:33:35 Dave Newton wrote:
> --- On Tue, 9/2/08, Roger wrote:
> > The parameter "name" in the test case exists in the model
> > (TestQuotation) but not in the action (TestAction) and
> > Struts2 bleats in the Tomcat logs. It's definitely being
> > set in the model
>
> Like I said, it can be ignored, and the link I provided seems to indicate
> that the log level of the message was changed.
>
> Ah, you're using paramsPrepareParams... so the reason you're seeing the
> message is that the paramsPrepareParams stack has one of its params
> interceptors before modelDriven.
>

I'm only using this stack as it's the out-of-the-box default. Should I be 
using something else? 

> This means the model won't have been pushed on the stack yet when the first
> params hits, so the first time through it'll attempt to set the parameter
> on the action.
>
> The second time params is hit the model is on the stack, so no error.
> Adding a field to the JSP not available in either the action or model will
> demonstrate the behavior.

Of course - obvious now that you've explained it.

Once again, thanks for your help.

Regards

---------------------------------------------------------------------
To unsubscribe, e-mail: user-unsubscribe@struts.apache.org
For additional commands, e-mail: user-help@struts.apache.org


Mime
View raw message