struts-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Becky.L.O'Sulli...@healthnet.com
Subject Re: To .action or not to .action.
Date Fri, 13 Mar 2009 20:35:12 GMT
We've been posting our URLs that way (sans .action) for a while now and we
love it.  Please don't make it go away.  :)

-B




                                                                           
             DEck@holstein.com                                             
                                                                           
             03/13/2009 01:24                                           To 
             PM                        "Struts Users Mailing List"         
                                       <user@struts.apache.org>            
                                                                        cc 
             Please respond to                                             
               "Struts Users                                       Subject 
               Mailing List"           Re: To .action or not to .action.   
             <user@struts.apac                                             
                  he.org>                                                  
                                                                           
                                                                           
                                                                           
                                                                           






I believe it's now the default behavior of struts 2.1.



We recently discovered, quite by accident, that we can cause our app
built on struts2 to NOT display ".action" on any of the URL's.  I'd
simply like to find out if this is an intended feature or a possible
defect?  The difference is in how we start off our interaction in the
browser.  If we use a URL like:

    http://localhost:8080/mysite/login.action

then all of the URL's in the site appear to be suffixed with ".action".
If, on the other hand, we use:

    http://localhost:8080/mysite/login

then none of the URL's are suffixed with ".action".

We're using Struts 2.1.6 with Tiles 2.0.4 - recently upgraded from some
prior versions.  We noticed this because our QE department's automated
testing software freaked out when it couldn't match URL's as it expected.

Thanks,
Dave

---------------------------------------------------------------------
To unsubscribe, e-mail: user-unsubscribe@struts.apache.org
For additional commands, e-mail: user-help@struts.apache.org




This e-mail and any files transmitted with it are confidential and intended
solely for the use of the individual(s) or entity to whom they are
addressed.
 If you receive this e-mail in error please notify postmaster@holstein.com.


---------------------------------------------------------------------
To unsubscribe, e-mail: user-unsubscribe@struts.apache.org
For additional commands, e-mail: user-help@struts.apache.org





---------------------------------------------------------------------
This message, together with any attachments, is
intended only for the use of the individual or entity
to which it is addressed. It may contain information
that is confidential and prohibited from disclosure.
If you are not the intended recipient, you are hereby
notified that any dissemination or copying of this
message or any attachment is strictly prohibited. If
you have received this message in error, please notify
the original sender immediately by telephone or by
return e-mail and delete this message, along with any
attachments, from your computer. Thank you.

---------------------------------------------------------------------

---------------------------------------------------------------------
To unsubscribe, e-mail: user-unsubscribe@struts.apache.org
For additional commands, e-mail: user-help@struts.apache.org


Mime
View raw message