struts-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Struts Two <struts...@yahoo.ca>
Subject Re: Migrate Struts 1.0 app from WebSphere 5.1 to 6.1 - JSP container failed to load the TagExtraInfo
Date Wed, 13 May 2009 13:17:11 GMT

I know when I migrated my struts 1.1 apps from Websphere 5.1 to Websphere 6.x, I had to add
the a property to custom server properties to make it work, Go to :

Application servers > [ur server name] > Web container > Custom properties

and then add the following property:

prependSlashToResource = true

Let's hope this will solve ur problem.



--- On Tue, 5/12/09, mule_user <sgho@aol.com> wrote:

> From: mule_user <sgho@aol.com>
> Subject: Migrate Struts 1.0 app from WebSphere 5.1 to 6.1 - JSP container failed to load
the TagExtraInfo
> To: user@struts.apache.org
> Received: Tuesday, May 12, 2009, 7:54 PM
> 
> The same code (EAR) did not throw the above exceptions in
> WebSphere 5.1
> server. 
> 
> Migrating Struts 1.0 application from WebSphere 5.1 to
> WebSphere 6.1 in
> z/OS. After successfully deploying Struts 1.0 app in
> WebSphere 6.1 server, I
> start the application. As the application starts up, I get
> the following
> error in server log as:
> 
> Trace: 2009/05/11 15:57:57.713 01 t=9CCC68 c=UNK key=P8
> (13007002)              
>   ThreadId: 000000e3         
>                
>                
>                
>   
>   FunctionName: endElement       
>                
>                
>               
>   SourceId: com.ibm.ws.jsp       
>                
>                
>               
>   Category: WARNING         
>                
>                
>                
>    
>   ExtendedMessage: JSPG0235E: The JSP container failed
> to load the
> TagExtraInfo class .org.apache.struts.taglib.EnumerateTei.
> Trace: 2009/05/11 15:57:57.713 01 t=9CCC68 c=UNK key=P8
> (0000000A)              
>   Description: Log Java Message     
>                
>                
>            
>   Message: JSPG0235E: The JSP container failed to load
> the TagExtraInfo
> class .org.apache.struts.taglib.EnumerateTei.
> 
> Trace: 2009/05/11 15:57:57.717 01 t=9CCC68 c=UNK key=P8
> (13007002)              
>   ThreadId: 000000e3         
>                
>                
>                
>   
>   FunctionName: endElement       
>                
>                
>               
>   SourceId: com.ibm.ws.jsp       
>                
>                
>               
>   Category: WARNING         
>                
>                
>                
>    
>   ExtendedMessage: JSPG0235E: The JSP container failed
> to load the
> TagExtraInfo class .org.apache.struts.taglib.IterateTei.
> Trace: 2009/05/11 15:57:57.717 01 t=9CCC68 c=UNK key=P8
> (0000000A)              
>   Description: Log Java Message     
>                
>                
>            
>   Message: JSPG0235E: The JSP container failed to load
> the TagExtraInfo
> class .org.apache.struts.taglib.IterateTei.
> 
> Trace: 2009/05/11 16:03:19.143 01 t=9C6E88 c=UNK key=P8
> (13007002)              
>   ThreadId: 00000055         
>                
>                
>                
>   
>   FunctionName: endElement       
>                
>                
>               
>   SourceId: com.ibm.ws.jsp       
>                
>                
>               
>   Category: WARNING         
>                
>                
>                
>    
>   ExtendedMessage: JSPG0235E: The JSP container failed
> to load the
> TagExtraInfo class .org.apache.struts.taglib.html.TextTei.
> Trace: 2009/05/11 16:03:19.144 01 t=9C6E88 c=UNK key=P8
> (0000000A)              
>   Description: Log Java Message     
>                
>                
>            
>   Message: JSPG0235E: The JSP container failed to load
> the TagExtraInfo
> class .org.apache.struts.taglib.html.TextTei.
> 
> This seems to be a known issue.  We found similar
> posting in IBM forum as:
> 
> http://www.ibm.com/developerworks/forums/thread.jspa?threadID=179489&tstart=0
> 
> But the answer was not comprehensive.
> 
> Note that the same code (EAR) did not throw the above
> exceptions in
> WebSphere 5.1 server.
> 
> An example of our struts.tld is:
> 
> <tlibversion>1.0</tlibversion>
>   <jspversion>1.1</jspversion>
>   <shortname>STRUTS Framework Tag
> Library</shortname>
>   <uri>http://jakarta.apache.org/taglibs/struts-1.0</uri>
>   
>   <tag>
>     <name>enumerate</name>
>    
> <tagclass>org.apache.struts.taglib.EnumerateTag</tagclass>
>    
> <teiclass>org.apache.struts.taglib.EnumerateTei</teiclass>
>     <bodycontent>JSP</bodycontent>
> 
> We would like to know what steps need to be taken to
> resolve this issue. 
> 
> 1. Please show an example of what exact changes need to be
> made in both
> struts.tld and web.xml?
> 2. Instead of making the changes in both struts.tld and
> web.xml, what exact
> parameter needs to be added in WAS 6.1 server?
> 3. What are the implications for not being able to load
> these classes? Even
> though I am getting errors saying that these classes are
> not getting loaded,
> the Struts 1.0 application successfully starts and
> functions correctly in
> WebSphere 6.1 server.
> 
> Again, note that the exact same code (EAR) base did not
> throw the above
> exceptions in WebSphere 5.1 server.
> 
> 
> 
> -- 
> View this message in context: http://www.nabble.com/Migrate-Struts-1.0-app-from-WebSphere-5.1-to-6.1---JSP-container-failed-to-load-the-TagExtraInfo-tp23509213p23509213.html
> Sent from the Struts - User mailing list archive at
> Nabble.com.
> 
> 
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: user-unsubscribe@struts.apache.org
> For additional commands, e-mail: user-help@struts.apache.org
> 
> 


      __________________________________________________________________
Ask a question on any topic and get answers from real people. Go to Yahoo! Answers and share
what you know at http://ca.answers.yahoo.com

---------------------------------------------------------------------
To unsubscribe, e-mail: user-unsubscribe@struts.apache.org
For additional commands, e-mail: user-help@struts.apache.org


Mime
View raw message