struts-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Dave Newton <newton.d...@yahoo.com>
Subject Re: upgrading to S2.1.6 - ClassNotFoundException:org.springframework.core.SmartClassLoader
Date Tue, 12 May 2009 13:26:49 GMT
David Canos wrote:
> I have upgraded an application to Struts 2.1.6. and error says:
> ClassNotFoundException:org.springframework.core.SmartClassLoader
> I have used all the libs that are attached in struts-2.1.6-all.zip.
> are all that libs correct?

I find it unlikely. You should use the *actual dependencies* of the 
libraries you're using, regardless of what's downloaded. If you're not 
using Maven you can resolve it manually through any of the Maven 
dependency listing sites. Manual dependency resolution is a PITA.

> I assume this have been tested before packed.

Why? I've found it's best not to make assumptions when it's not my code.

The first thing I would try is using the spring-all jar of the proper 
version as a sanity check.

Dave


---------------------------------------------------------------------
To unsubscribe, e-mail: user-unsubscribe@struts.apache.org
For additional commands, e-mail: user-help@struts.apache.org


Mime
View raw message