struts-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Musachy Barroso <musa...@gmail.com>
Subject Re: Javatemplates plugin error in 2.1.7 with struts2-blank.war
Date Tue, 12 May 2009 13:51:14 GMT
A patch was recently applied to the templates plugin, and maybe
something is broken. I will take a look, thanks for reporting.

musachy

On Tue, May 12, 2009 at 9:13 AM, Thomas Terrace <tterrace@gmail.com> wrote:
> Has anyone else been able to use the java templates plugin
> successfully with 2.1.7? Using struts2-blank-2.1.7.war compiled from
> source yesterday, I dropped the javatemplates 2.1.7 jar into lib and
> added the following lines to struts.xml:
>
>
>
>     <constant name="struts.ui.templateSuffix" value="java" />
>     <constant name="struts.ui.theme" value="simple" />
>
>
>  The error:
>
>
>
> SEVERE: Could not open template
> java.lang.RuntimeException: java.lang.RuntimeException:
> com.opensymphony.xwork2.inject.DependencyException:
> com.opensymphony.xwork2.inject.ContainerImpl$MissingDependencyException:
> No mapping found for dependency [type=java.lang.String,
> name='struts.javatemplates.customThemes'] in public void
> org.apache.struts2.views.java.JavaTemplateEngine.setThemeClasses(java.lang.String).
>
>
> Following the same process with 2.1.6 works normally (tested on
> tomcat6 and weblogic 10.3).
> Any help is appreciated,
> Tom
>
> --
> Sent from my mobile device
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: user-unsubscribe@struts.apache.org
> For additional commands, e-mail: user-help@struts.apache.org
>
>



-- 
"Hey you! Would you help me to carry the stone?" Pink Floyd

---------------------------------------------------------------------
To unsubscribe, e-mail: user-unsubscribe@struts.apache.org
For additional commands, e-mail: user-help@struts.apache.org


Mime
View raw message