struts-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From wkbutler <kent.but...@gmail.com>
Subject Re: Is 'expression' a keyword in 2.1.6?
Date Fri, 24 Jul 2009 03:54:31 GMT

Answer appears to be 'no' after renaming the object and fields. Looks like
something else changed.


wkbutler wrote:
> 
> Hi - this may be a dumb question, but I'm having a validation issue since
> upgrading to 2.1.6  (at least I think that's when it started).
> 
> Saving an entity called 'Expression' fails - always fails the validation
> for field-validator 'requiredstring'.  Here is the validator definition:
> 
> <!DOCTYPE validators PUBLIC "-//OpenSymphony Group//XWork Validator
> 1.0.2//EN"
>     "http://www.opensymphony.com/xwork/xwork-validator-1.0.2.dtd">
> <validators>
>     <field name="expression.expression">
>         <field-validator type="requiredstring">
>             <message key="errors.required"/>
>         </field-validator>
>     </field>
>     <field name="expression.expressionType">
>         <field-validator type="requiredstring">
>             <message key="errors.required"/>
>         </field-validator>
>     </field>
>     <field name="expression.returnType">
>         <field-validator type="requiredstring">
>             <message key="errors.required"/>
>         </field-validator>
>     </field>
> </validators>
> 
> 
> and the debug result while saving, showing that there is data in all 3
> fields:
> 
> 
> DEBUG [btpool0-4] ParametersInterceptor.debug(57) | Setting params
> expression.createDate => [ 07/21/2009 ] expression.createUser => [ -2 ]
> expression.deleteDate => [  ] expression.deleteUser => [  ]
> expression.expression => [ test ] expression.expressionId => [ 3 ]
> expression.expressionType => [ FTL ] expression.lastUpdate => [ 07/22/2009
> ] expression.lastUpdateUser => [ -2 ] expression.returnType => [ Number ]
> method:cancel => [ Cancel ] questionId => [ 545 ] 
> 
> 
> All 3 required fields fail with messages  "XXX is a required field".
> 
> Changing the field-validator to just "required" doesn't help.   
> 
> Before I rename this entity and all it's relatives, I thought I'd ask here
> to see if anyone knows if this has become a keyword.  I'm pretty darn sure
> this worked for me before I upgraded to 2.1.6, at least when I originally
> built it back in April/May.   
> 
> Thanks for ideas -
> Kent
> 
> 

-- 
View this message in context: http://www.nabble.com/Is-%27expression%27-a-keyword-in-2.1.6--tp24629754p24638252.html
Sent from the Struts - User mailing list archive at Nabble.com.


---------------------------------------------------------------------
To unsubscribe, e-mail: user-unsubscribe@struts.apache.org
For additional commands, e-mail: user-help@struts.apache.org


Mime
View raw message