struts-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From mailtolouis2020-str...@yahoo.com
Subject Re: Problem with LoginInterceptor
Date Mon, 20 Jul 2009 14:13:16 GMT
I don't think it will preserve your parameter by default, I might be wrong, if it do, then
that is another magic in S2 I didn't know that.

For what I understand is there are 2 request from the user,
1) http://localhost:8080/projektseminar/rating/Rate?staffResourceId=1
2) login submit

I don't think you store a staffResourceId as a hidden param in the login page, if its not
there you won't expect to come into your url.

Regards
Louis


________________________________
From: mathias-ewald <nitehoaxxer@gmx.net>
To: user@struts.apache.org
Sent: Monday, July 20, 2009 2:53:39 PM
Subject: Re: Problem with LoginInterceptor


Hi,

yes I am using the latest version of struts2. Most likely the tutorials I
used refer to other versions. I set the struts.xml as follows:

---------------------------------------------------
        <interceptors>
            <interceptor name="login"
class="de.mathiasewald.projektseminar.interceptor.LoginInterceptor" />
            
            <interceptor-stack name="defaultLoginStack">
                <interceptor-ref name="servletConfig" />
                <interceptor-ref name="params" />
                <interceptor-ref name="login" />
                <interceptor-ref name="prepare" />
                <interceptor-ref name="chain" />
                <interceptor-ref name="modelDriven" />
                <interceptor-ref name="fileUpload" />
                <interceptor-ref name="staticParams" />
                <interceptor-ref name="params" />
                <interceptor-ref name="conversionError" />
                <interceptor-ref name="validation" />
                <interceptor-ref name="workflow" />
            </interceptor-stack>

            <interceptor-stack name="defaultInsecureStack">
                <interceptor-ref name="servletConfig" />
                <interceptor-ref name="params" />
                <interceptor-ref name="prepare" />
                <interceptor-ref name="chain" />
                <interceptor-ref name="modelDriven" />
                <interceptor-ref name="fileUpload" />
                <interceptor-ref name="staticParams" />
                <interceptor-ref name="params" />
                <interceptor-ref name="conversionError" />
                <interceptor-ref name="validation" />
                <interceptor-ref name="workflow" />
            </interceptor-stack>
        </interceptors>
---------------------------------------------------

The errors about unfindable interceptors disappeard. But still, the
parameter is not preserved.

Any suggestions?

cu
mathias
-- 
View this message in context: http://www.nabble.com/Problem-with-LoginInterceptor-tp24565562p24570331.html
Sent from the Struts - User mailing list archive at Nabble.com.


---------------------------------------------------------------------
To unsubscribe, e-mail: user-unsubscribe@struts.apache.org
For additional commands, e-mail: user-help@struts.apache.org
Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message