struts-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Raghuveer.V" <raghuve...@infotechsw.com>
Subject Struts2 on Websphere 6.1 : 404 errors
Date Fri, 16 Oct 2009 13:03:34 GMT
Hi Struts2 Users,
I have problem when deploying application struts2.1.6 application on
Websphere6.1 which was succefully working on apache-tomcat-5.5.23.
We have used configuration option to make it work as per information
available in Websphere forums and Struts2 forums on my local websphere.
 
Could you suggest is this the ONLY possible solution to make struts2 work on
Websphere?.
 
 
Initially we have received 404 errors.
Servlet filter is not called for URL resources on WAS 6.1 , configuration
option has been set in server 
 

The webcontainer custom property
com.ibm.ws.webcontainer.invokefilterscompatibility was  set to true as per
below links.

com.ibm.ws.webcontainer.invokefilterscompatibility=true

Application Servers -> <server> -> Web Container Settings -> Web Container
-> Custom Properties

 

 

Goggle Refrence: 

 

struts2 +websphere +There is no Action mapped for namespace / and action
name

com.ibm.ws.webcontainer.invokefilterscompatibility+struts2+websphere

 

http://www.ibm.com/developerworks/forums/thread.jspa?threadID=264848

http://www-01.ibm.com/support/docview.wss?rs=180
<http://www-01.ibm.com/support/docview.wss?rs=180&uid=swg1PK27620>
&uid=swg1PK27620

http://www.mail-archive.com/user@struts.apache.org/msg88798.html

http://www.nabble.com/Struts2-on-Websphere-portal-6.1.0.0-td18761735.html

 

 

 

Regards,
Raghu

 


Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message