struts-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From sonavor ...@worleytown.com>
Subject Re: Problem adding sslext to Struts application
Date Mon, 05 Oct 2009 21:29:17 GMT

Some additional information -

I added some debug logging to monitor the URL requests passing through my
Struts application servlet filter.

For the HTTP requests I see my logs in the tomcat server log.  For example I
see -

request URI: /MyWebApp/

and 

request URI: /MyWebWeb/sectPh.do

When I click on my link for user registration -
https://localhost/MyWebApp/register.do;jsessionid=6A98EBF46D98CEA31ADF9332A1CB8651

I only get the error message
Not Found
The requested URL
/MyWebApp/register.do;jsessionid=6A98EBF46D98CEA31ADF9332A1CB8651 was not
found on this server.

So that is from the Apache 2.2 web server and the request is never sent to
my Tomcat 5.5 server for processing.  There must be some additional
configuration that needs to be in place on the Apache to Tomcat connector.

-sonavor


sonavor wrote:
> 
> I am trying to provide http/https switching on some URL patterns in my web
> application.  This web application is running on Tomcat 5.5 and is using
> Apache 2.2 as the web server.  The version of Struts that I am using is
> 1.2.9.
> 
> I have the Apache 2.2 web server setup with a self-signed certificate and
> it works fine.  In the Struts application I have added the necessary
> sslext.jar and the tld as well as modified the struts-config.xml (and
> necessary JSP sections).  Everything compiles and all of the non-SSL pages
> work fine.
> 
> The problem I am having is with the links and pages that I have set to
> require HTTPS.  For example, the login screen.  I set my login path in my
> Struts configuration file like this -
> <action path="/secure/userLogin" forward="/secure/Welcome.do">
>       <set-property property="secure" value="true"/>
> </action>
> 
> In the JSP I am using the sslext:link tag like this -
> <sslext:link action="/secure/userLogin.do"
> styleClass="logintext">Login</sslext:link>
> 
> When the application is running the login link looks correct to me -
> https://localhost/MyWebApp/secure/userLogin.do;jsessionid=263BFC7F3E6E33BAAC22A28723763FA4
> 
> However, when I try the link I end up with this failure message -
> Not Found
> The requested URL
> /MyWebApp/register.do;jsessionid=263BFC7F3E6E33BAAC22A28723763FA4 was not
> found on this server.
> 
> I can change the Struts config action definition to this -
> <action path="/secure/userLogin" forward="/secure/Welcome.do">
>       <set-property property="secure" value="false"/>
> </action>
> 
> and the login link will change to -
> http://localhost/MyWebApp/secure/userLogin.do
> 
> That login works (but it uses HTTP and not HTTPS). 
> 
> Does anyone know why the Struts action path is not being found when HTTPS
> is turned on?
> 
> Thanks,
> -sonavor
> 
> 
> 
> 
> 

-- 
View this message in context: http://www.nabble.com/Problem-adding-sslext-to-Struts-application-tp25756892p25757022.html
Sent from the Struts - User mailing list archive at Nabble.com.


---------------------------------------------------------------------
To unsubscribe, e-mail: user-unsubscribe@struts.apache.org
For additional commands, e-mail: user-help@struts.apache.org


Mime
View raw message