struts-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Henry Jen <henry...@ztune.net>
Subject Re: Upgrade 2.1.6 to 2.1.8.1, <s:a> cause empty <a /> tag?
Date Wed, 02 Dec 2009 07:12:26 GMT
2009/12/1 Saeed Iqbal <saeedcs@gmail.com>:
> Is your Ajax configured?

Sorry for my ignorance, we don't use ajax with struts, not sure what
need to be configured. Would you shed some light for me?

Cheers,
Henry

>
> On Wed, Dec 2, 2009 at 12:45 PM, Henry Jen <henryjen@ztune.net> wrote:
>
>> Hi,
>>
>> I updated our project using 2.1.6 to 2.1.8.1 and surprised to find
>> that <s:a> tag breaks the application.
>>
>> An example is
>> <s:a href="#" tabindex="3">Login</s:a>
>> renders to in 2.1.8.1
>> <a tabindex="3" href="#"/>
>>
>> When I looked into the simple template, seems like the change in a.ftl
>> and a-close.ftl is causing this.
>>
>> In 2.1.8, the a.ftl basically moved into a-close.ftl and using
>> ${parameters.body} in between.
>>
>> >${parameters.body}</a>
>>
>> I don't believe this is a bug as it is obvious, does this mean the
>> usage of <s:a> changed?
>>
>> FWIW, I am using struts in a maven project, so dependencies is
>> retrieved by maven.
>>
>> Cheers,
>> Henry
>>
>> ---------------------------------------------------------------------
>> To unsubscribe, e-mail: user-unsubscribe@struts.apache.org
>> For additional commands, e-mail: user-help@struts.apache.org
>>
>>
>
>
> --
> Saeed Iqbal
> Independant Consultant (Freelance)
> Struts - J2EE - Application Architect / Developer
>

---------------------------------------------------------------------
To unsubscribe, e-mail: user-unsubscribe@struts.apache.org
For additional commands, e-mail: user-help@struts.apache.org


Mime
View raw message