struts-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Ken <ken.mcwilli...@aerose.com>
Subject Re: Migration problem from 2.0.x to 2.1.6
Date Fri, 28 May 2010 21:08:35 GMT
I am now experiencing the same error.

There is no Action mapped for namespace / and action name welcome. -
[unknown location]
        at
com.opensymphony.xwork2.DefaultActionProxy.prepare(DefaultActionProxy.java:178)
        at
org.apache.struts2.impl.StrutsActionProxy.prepare(StrutsActionProxy.java:61)

Added <constant name="struts.action.extension" value="action" /> to my
struts.xml configuration

<struts>
    <constant name="struts.action.extension" value="action" />
    <!-- Configuration for the default package. -->
    <package name="default" namespace="/" extends="tiles-default">
        <result-types>
            <result-type name="tiles"
            class="org.apache.struts2.views.tiles.TilesResult"
            default="true"/>
        </result-types>
        <action name="welcome" class="home.Index">
            <result name="success">welcome</result>
        </action>
    </package>
    <include file="strutsConfig/struts_secure.xml"/>
</struts>

Didn't work so did the next part changed web.xml to use
org.apache.struts2.dispatcher.ng.filter.StrutsPrepareAndExecuteFilter

<web-app version="2.5" xmlns="http://java.sun.com/xml/ns/javaee"
xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
xsi:schemaLocation="http://java.sun.com/xml/ns/javaee
http://java.sun.com/xml/ns/javaee/web-app_2_5.xsd">
    <filter>
        <filter-name>struts2</filter-name>

<filter-class>org.apache.struts2.dispatcher.ng.filter.StrutsPrepareAndExecuteFilter</filter-class>
    </filter>
    <filter-mapping>
        <filter-name>struts2</filter-name>
        <url-pattern>*.action</url-pattern>
    </filter-mapping>

    <filter-mapping>
        <filter-name>struts2</filter-name>
        <url-pattern>/struts/*</url-pattern>
    </filter-mapping>
    <session-config>
        <session-timeout>
            30
        </session-timeout>
    </session-config>
    <welcome-file-list>
        <welcome-file>home/index.jsp</welcome-file>
    </welcome-file-list>
    <context-param>
        <param-name>

org.apache.titles.impl.BasicTilesContainer.DEFINITIONS_CONFIG
        </param-name>
        <param-value>WEB-INF/tiles.xml</param-value>
    </context-param>
    <listener>
        <listener-class>
            org.apache.tiles.web.startup.TilesListener
        </listener-class>
    </listener>
</web-app>

I was getting two errors about not being able to load tiles-default
before that...
Still same error,
Then removed  <constant name="struts.action.extension" value="action" />
Still same error.

Suggestions?

On Fri, 2010-05-28 at 08:23 -0400, Greg Lindholm wrote:

> Here is a link to the same page that is working
> 
> https://cwiki.apache.org/confluence/display/S2WIKI/Troubleshooting+guide+migrating+from+Struts+2.0.x+to+2.1.x
> 
> 
> On Fri, May 28, 2010 at 4:35 AM, Gwen Harold Autencio
> <gwenharold20@yahoo.com> wrote:
> > Ahh I see thanks .. i'll read on it ..
> >
> > --- On Thu, 5/27/10, Greg Lindholm <greg.lindholm@gmail.com> wrote:
> >
> >> From: Greg Lindholm <greg.lindholm@gmail.com>
> >> Subject: Re: Migration problem from 2.0.x to 2.1.6
> >> To: "Struts Users Mailing List" <user@struts.apache.org>
> >> Date: Thursday, May 27, 2010, 10:50 PM
> >> Check out the wiki entry for
> >> migrating
> >>
> >> https://cwiki.apache.org/S2WIKI/troubleshooting-guide-migrating-from-struts-20x-to-21x.html
> >>
> >> There is a section "Filter Mapping, default Action
> >> extensions, and
> >> Servlets" that should help.
> >>
> >> Unfortunately the docs seem to still be messed up.
> >> ....sigh
> >>
> >>
> >> On Thu, May 27, 2010 at 1:48 AM, Gwen Harold Autencio
> >> <gwenharold20@yahoo.com>
> >> wrote:
> >> > Hi,
> >> >
> >> > I got a Servlet which doesn't extends to an action.
> >> Looking for a work around without extending the servlet to
> >> an action because it's already has extends another class.
> >> > Any ideas ?
> >> >
> >> > I'm getting this in the logs
> >> >
> >> > 2010-05-27 13:46:44,962 [btpool0-8] WARN
> >>  org.apache.struts2.dispatcher.Dispatcher  - Could not
> >> find action or result
> >> > There is no Action mapped for namespace / and action
> >> name repository/internal/. - [unknown location]
> >> >        at
> >> com.opensymphony.xwork2.DefaultActionProxy.prepare(DefaultActionProxy.java:177)
> >> >        at
> >> org.apache.struts2.impl.StrutsActionProxy.prepare(StrutsActionProxy.java:61)
> >> >        at
> >> org.apache.struts2.impl.StrutsActionProxyFactory.createActionProxy(StrutsActionProxyFactory.java:39)
> >> >        at
> >> com.opensymphony.xwork2.DefaultActionProxyFactory.createActionProxy(DefaultActionProxyFactory.java:47)
> >> >        at
> >> org.apache.struts2.dispatcher.Dispatcher.serviceAction(Dispatcher.java:458)
> >> >



Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message