struts-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Michelle Weeks" <michelle.we...@JETISRE.COM>
Subject RE: Struts 2.2.1 Problem
Date Wed, 22 Sep 2010 15:56:49 GMT
I guess I'm not sure what exactly you are asking ...

My project uses the core Struts components as well as the Struts portlet
components.  All of the portlets we are having the issue in are pretty
basic, using just the portletDefaultStack and basicStack interceptors.
One of the Hash Maps that is not setting simply has a String key and a
String value.  If I find a key that does not contain a special
character, the data saves.  If one key has a special character the whole
Map is not set into the action. 

-----Original Message-----
From: Dave Newton [mailto:davelnewton@gmail.com] 
Sent: Wednesday, September 22, 2010 10:21 AM
To: Struts Users Mailing List
Subject: Re: Struts 2.2.1 Problem

Under what circumstances?

On Wed, Sep 22, 2010 at 11:20 AM, Michelle Weeks
<michelle.weeks@jetisre.com
> wrote:

> I have just started using Struts 2.2.1, and I have found a bug ... I
> have several Hash Maps with a String for the key value.  These key
> values sometimes contain special characters, including '-, /, \, _'
any
> Map with a key value containing one of these characters seems to
> silently fail to call the set method.  Any ideas on a fix??
>

---------------------------------------------------------------------
To unsubscribe, e-mail: user-unsubscribe@struts.apache.org
For additional commands, e-mail: user-help@struts.apache.org


Mime
View raw message