struts-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From DavidZaz <dzaze...@cait.org>
Subject Multipart/Form-Data with Struts 1
Date Tue, 05 Oct 2010 14:16:55 GMT

I have a legacy application using Struts 1.2.8 and I have the following HTML
form:

<html:form action="/myAction.do" method="post"
enctype="multipart/form-data">
     <html-el:textarea property="userEnteredHtml" styleClass="tinyMCE"
styleId="tinymce"></html-el:textarea>
</html:form>

If I include multiple blank lines in the tinyMCE editor, the generated HTML
should be:

<p>&nbsp;</p>

However, IE posts the following HTML:

<p>Â </p>

At first glance, I thought that this was exclusively a tinyMCE problem and I
posted on their forum. However, the problem goes away when I remove the
enctype="multipart/form-data" from the html:form declaration. Does Struts 1
do anything unusual with the enctype multipart/form-data attribute? It does
not seem that other tinyMCE editor users are experiencing this issue (since
they probably aren't using Struts 1).

Is there any alternative to using multipart/form-data? My form does include
a file upload which is why I initially added the multipart/form-data.
-- 
View this message in context: http://old.nabble.com/Multipart-Form-Data-with-Struts-1-tp29887777p29887777.html
Sent from the Struts - User mailing list archive at Nabble.com.


---------------------------------------------------------------------
To unsubscribe, e-mail: user-unsubscribe@struts.apache.org
For additional commands, e-mail: user-help@struts.apache.org


Mime
View raw message