struts-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Maurizio Cucchiara <maurizio.cucchi...@gmail.com>
Subject Re: Reg: Issue with Struts 2 & Tomcat Realm
Date Fri, 19 Nov 2010 09:54:02 GMT
I guess that tomcat auth manager doesn't chain your request through struts
filter.

I'm not sure it works, but you could try to add this line inside your
struts's servlet mapping declaration:


       <filter-mapping>
                <filter-name>struts2</filter-name>
                <url-pattern>/*</url-pattern>
                <dispatcher>FORWARD</dispatcher>
                <dispatcher>INCLUDE</dispatcher> <!-- <- this one should
be
unnecessary  -->
        </filter-mapping>

2010/11/19 Sathish Kumar <sathishkumar.thiyagarajan@gmail.com>

> Hi Group,
>
> We are using  Tomcat 6 based Container Managed
> Security<http://tomcat.apache.org/tomcat-6.0-doc/realm-howto.html>where
> we can declare a login page which will be displayed whenever someone
> access secured urls. If we look at the samples, the login page is given as
> jsp ( login.jsp ). like below
>
>        <*login*-config>
>                <auth-method>*FORM*</auth-method>
>                <*form*-*login*-config>
>
> <*form*-*login*-page>/*login*.*jsp*</*form*-*login*-page>
>
>
> <*form*-error-page>/*login*.*jsp?error=true*</*form*-error-page>
>
>                </*form*-*login*-config>
>        </*login*-config>
>
> Now, the issue is this .... In our environment we use kind of tiles in
> which
> the layout will be separated from pages. and for this reason i want to set
> a
> action class as my login page. something like
>
>                        <*form*-*login*-page>/*login*.*action*</*form*-*
> login*-page>
>
> But this time, i am getting resource not found error ( even though
> login.action exists in the application ). When i googled about this, i got
> the below question from some other struts 2 user.
>
>
> http://struts-2.464677.n5.nabble.com/Attempting-FORM-authentication-with-Tomcat6-Tiles-and-failing-badly-td464758.html
>
> Is this the issue with struts or tomcat ? any of have faced/solved this
> issue before ?
>
> It will be great if you can give me some pointers to proceed this issue ..
>
> Regards,
> Sathish Kumar T
>



-- 
Maurizio Cucchiara

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message