struts-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Łukasz Lenart <lukasz.len...@googlemail.com>
Subject Re: strange behavior of s:a tag with s:include tag inside
Date Sun, 03 Jul 2011 17:39:55 GMT
I don't know why it happens that way. I've changed a bit templates by
moving some code from a-close.ftl to a.ftl and now it works as you've
been expecting. But that change broken few tests and can be backward
incompatible.


Regards
-- 
Łukasz
+ 48 606 323 122 http://www.lenart.org.pl/
Warszawa JUG conference - Confitura http://confitura.pl/


2011/7/1 Александр Высоков <node81@gmail.com>:
> Do you mean
> <s:url action="test2" var="ac"/>
> <s:include value="%{ac}"/>
> ?
>
> Tried. Empty body of a tag.
>
>
> 2 июля 2011 г. 0:56 пользователь Dave Newton <davelnewton@gmail.com>написал:
>
>> 2011/7/1 Александр Высоков <node81@gmail.com>:
>> > Dave, if I expressed roughly, I am very sorry (my bad english is not good
>> enough).
>>
>> Nope, you're doing great :)
>>
>> Try using a link to an action in the <s:include> tag instead of a plain
>> JSP.
>>
>> For now you could just create a class-less action mapping that
>> forwards to the JSP you're currently using. See if the behavior
>> continues.
>>
>> Dave
>>
>> ---------------------------------------------------------------------
>> To unsubscribe, e-mail: user-unsubscribe@struts.apache.org
>> For additional commands, e-mail: user-help@struts.apache.org
>>
>>
>
>
> --
> С уважением, Александр.
>

---------------------------------------------------------------------
To unsubscribe, e-mail: user-unsubscribe@struts.apache.org
For additional commands, e-mail: user-help@struts.apache.org


Mime
View raw message