struts-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From JOSE L MARTINEZ-AVIAL <jlm...@gmail.com>
Subject Re: Struts 2 WW-1714: "Using the Redirect Action Result withparameters to the target action causes an OGNL warning" still fails
Date Thu, 08 Sep 2011 19:54:59 GMT
Maurizio,
   I think I have some confusion here, so please correct me if I'm wrong.
Reading again the issue in JIRA, I understand that the correction was to
change the log level for that error to DEBUG, so it is still there, but it
would only appear if the log level is setup to DEBUG, and the devMode is set
to true. Is that right? Because I have the log level setup to DEBUG, but the
devMode is set to false, so it shouldn't be the case. I'm sorry, but the
description of the fix on JIRA doesn't seem very clear to me.

Thanks

JL

2011/9/8 Maurizio Cucchiara <mcucchiara@apache.org>

> I am sorry, but I am not able to reproduce it.
> This is what I did (please see [1] for further details):
> mvn archetype:generate -B \
>                       -DgroupId=tutorial \
>                       -DartifactId=tutorial \
>                       -DarchetypeGroupId=org.apache.struts \
>                       -DarchetypeArtifactId=struts2-archetype-blank \
>                       -DarchetypeVersion=2.2.3.1
> Then I opened example.xml and added what you wrote before (I only
> changed the jsp):
>
>      <action name="TestNavigateTo">
>          <result type="redirectAction">
>              <param name="actionName">NavigateTo</param>
>              <param name="navigateTo">Enroll1</param>
>          </result>
>      </action>
>      <action name="NavigateTo">
>           <result>/example/HelloWorld.jsp</result>
>      </action>
>
> Launched jetty with
> mvn jetty:run
>
> Now whenever I go to
> http://localhost:8080/tutorial/example/TestNavigateTo.action, Struts
> send a redirect to
> http://localhost:8080/tutorial/example/NavigateTo.action?navigateTo=Enroll1
>
> So, my guess is there is something with your current configuration
> (application server, environment, etc.)
>
> PS: FYI the latest release of Struts 2 is 2.2.3.1  (see
> http://struts.apache.org/2.2.3.1/index.html)
>
> [1] http://struts.apache.org/2.2.3/docs/struts-2-maven-archetypes.html
> Maurizio Cucchiara
>
>
>
> On 8 September 2011 14:19, JOSE L MARTINEZ-AVIAL <jlmagc@gmail.com> wrote:
> > I just have been able to replicate it on a blank Strus2 application
> > (Struts.2.2.3) I just added a package and a JSP to have something to
> > navigate to, and it is showing the same error message.
> >
> > 2011/9/8 JOSE L MARTINEZ-AVIAL <jlmagc@gmail.com>
> >
> >> Hi,
> >> I just added a very simple package to my app to test this. The package
> is
> >> defined as follows:
> >>
> >>     <package name="eco-test" namespace="/test" extends="json-default">
> >>         <action name="TestNavigateTo">
> >>             <result type="redirectAction">
> >>
> >>                 <param name="actionName">NavigateTo</param>
> >>                 <param name="navigateTo">Enroll1</param>
> >>             </result>
> >>         </action>
> >>         <action name="NavigateTo">
> >>             <result>/WEB-INF/jsp/test.jsp</result>
> >>         </action>
> >>     </package>
> >>
> >>    It's still failing when I use that action. Any thoughts?
> >>
> >> 2011/9/8 <jlmagc@gmail.com>
> >>
> >> Humm, I think I'm going to duplicate the two actions and go step by step
> >>> taking out my own additions(as you said Tiles and get back to the
> default
> >>> stack) and see on what moment it works fine. I'll let you know.
> >>>
> >>> Thanks
> >>>
> >>> JL
> >>> Sent via BlackBerry from T-Mobile
> >>>
> >>> -----Original Message-----
> >>> From: Maurizio Cucchiara <mcucchiara@apache.org>
> >>> Sender: maurizio.cucchiara@gmail.com
> >>> Date: Thu, 8 Sep 2011 10:44:36
> >>> To: Struts Users Mailing List<user@struts.apache.org>
> >>> Reply-To: "Struts Users Mailing List" <user@struts.apache.org>
> >>> Subject: Re: Struts 2 WW-1714: "Using the Redirect Action Result with
> >>>  parameters to the target action causes an OGNL warning" still fails
> >>>
> >>> Please forget my last mail, I mixed up the action name with the param
> >>> name.
> >>> Anyway I have been able to test your specific use case, using the
> >>> blank webapp, and it works like a charm (that is without throwing any
> >>> exception).
> >>> So, I guess we need to know some further details.
> >>> Also, could you try to change the result type from tiles to dispatcher
> >>> (the default value), in order to exclude that is something related to
> >>> tiles.
> >>>
> >>> Maurizio Cucchiara
> >>>
> >>>
> >>>
> >>> On 7 September 2011 20:35, JOSE L MARTINEZ-AVIAL <jlmagc@gmail.com>
> >>> wrote:
> >>> >  <result type="tiles">eco.login.navigate-to.screen</result>
> >>>
> >>> ---------------------------------------------------------------------
> >>> To unsubscribe, e-mail: user-unsubscribe@struts.apache.org
> >>> For additional commands, e-mail: user-help@struts.apache.org
> >>>
> >>>
> >>
> >
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: user-unsubscribe@struts.apache.org
> For additional commands, e-mail: user-help@struts.apache.org
>
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message