struts-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Miguel Almeida <mig...@almeida.at>
Subject Re: Performance issue with nested iterator
Date Thu, 05 Jul 2012 15:04:50 GMT
I believe I've found the culprit.
While the problem is present in commit
https://github.com/mmalmeida/struts-performance/commit/aba93098174c8c8c1684ffdd9bf332b212a893a
, it's not present in the latest commit if you turn devMode to false. 

The issue was the freemarker version 2.3.9 in that commit. Updating to
2.3.19 makes performance normal again (the complete project needed
freemarker, hence the direct dependency reference in the pom).

While I don't know what changed between these freemarker versions,
apparently the problem was there.

Miguel Almeida

On Thu, 2012-07-05 at 13:16 +0100, Miguel Almeida wrote:

> Sorry, I sent the email before explaining.
> 
> The repo has a maven project that I stripped down to the most basic to
> show the issue. Notice the iterator in index.jsp.
> 
> I tried to remove every unused configuration, file and dependency to
> make the project as simple as possible.
> 
> The original project is using tiles, so I kept it there. However, I
> don't think it's being used in the web workflow I created (which just
> goes to index.jsp).
> 
> Is there anything there that might explain this slowness?
> 
> Cheers,
> 
> Miguel Almeida
> 
> On Thu, 2012-07-05 at 13:05 +0100, Miguel Almeida wrote:
> 
> > Sure, Lukas:
> > 
> > https://github.com/mmalmeida/struts-performance
> > 
> > 
> > 
> > On Thu, 2012-07-05 at 06:48 +0200, Lukasz Lenart wrote:
> > 
> > > Could you post somewhere (GitHub) the whole code base ?
> > > 
> > > 
> > > Regards
> > 
> > 
> 
> 



Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message