struts-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Dave Newton <davelnew...@gmail.com>
Subject Re: iframes with struts2
Date Mon, 28 Jan 2013 21:23:06 GMT
Can you create a SSCCE and put it on github or somewhere?

Dave


On Mon, Jan 28, 2013 at 3:56 PM, Denise <denise.edwards@densweb.com> wrote:

> I removed the custom tag and still getting this problem.
>
> -----Original Message-----
> From: Denise [mailto:denise.edwards@densweb.com]
> Sent: Monday, January 28, 2013 1:37 PM
> To: 'Struts Users Mailing List'
> Subject: RE: iframes with struts2
>
> Ok I am not sure but there may be a conflict between a custom tag
> (originally created during struts1 implementation) and any struts2 tags.
>
> Without adding any struts2 tags the page renders fine. With a struts2 tag
> the custom tag's output (using jspWwriter's out ) does not complete and I'm
> guessing that's the reason for the blank page.
>
> Regards
> Denise
>
> -----Original Message-----
> From: Denise [mailto:denise.edwards@densweb.com]
> Sent: Monday, January 28, 2013 12:27 PM
> To: 'Struts Users Mailing List'; denise.edwards@densweb.com
> Subject: RE: iframes with struts2
>
> Also this output in the dos window..
> [DEBUG] [28 Jan 2013 12:24:22,671] [http-bio-8080-exec-12]
> (ApplicationDispatcher.java:407) -  Disabling the response for futher
> output
>
> -----Original Message-----
> From: Denise [mailto:denise.edwards@densweb.com]
> Sent: Monday, January 28, 2013 12:19 PM
> To: 'Struts Users Mailing List'
> Subject: RE: iframes with struts2
>
> I'm seeing a bunch of this in the debug output:
> 2013-01-28 12:01:34,984 [http-bio-8080-exec-4] DEBUG
>
> org.apache.catalina.core.ContainerBase.[Standalone].[localhost].[/appname].[
> jsp]-  Disabling the response for futher output
>
> I'm using tomcat7.
>
> I've searched the web and noticed a similar issue that another struts user
> has. This user is also using iframes/framesets and closely describes the
> issue I'm having. Unfortunately no real solution is posted.
>
> I'm still reviewing the logs. Any feedback on this would be appreciated.
>
> Regards
> Denise
>
>
> -----Original Message-----
> From: Dave Newton [mailto:davelnewton@gmail.com]
> Sent: Monday, January 28, 2013 10:54 AM
> To: Struts Users Mailing List; denise.edwards@densweb.com
> Subject: Re: iframes with struts2
>
> Turn up logging to debug level, turn devMode on, and check the logs again.
>
> You're certain that all JSPs in the iframes include the taglib directive?
>
>
> On Mon, Jan 28, 2013 at 10:48 AM, Denise <denise.edwards@densweb.com>
> wrote:
>
> > The result... The section where the iframe is placed on the screen,
> returns
> > a blank screen and with no error output.
> >
> > -----Original Message-----
> > From: Denise [mailto:denise.edwards@densweb.com]
> > Sent: Monday, January 28, 2013 10:45 AM
> > To: 'Struts Users Mailing List'
> > Subject: RE: iframes with struts2
> >
> > Thanks Dave for responding..
> >
> > This piece of code should render a drop down box populated with values
> from
> > a hashmap set in the associated actionsupport class. I've also tested by
> > adding a simple s:property code at the top of the page and the page stops
> > at
> > the first point where a struts tag is referenced.
> >
> >
> >
> > -----Original Message-----
> > From: Dave Newton [mailto:davelnewton@gmail.com]
> > Sent: Monday, January 28, 2013 10:37 AM
> > To: Struts Users Mailing List; denise.edwards@densweb.com
> > Subject: Re: iframes with struts2
> >
> > On Mon, Jan 28, 2013 at 10:28 AM, Denise <denise.edwards@densweb.com>
> > wrote:
> >
> > > I'm migrating webapp from struts1 to struts2. On one of the screens the
> > app
> > > uses an iframe. The frame file is not recognizing any struts2 tags. The
> > > taglib directive is present on all jsp files used for this iframe
> setup.
> > I
> > > have no problems referencing the struts2 tags in other areas of the
> app.
> > >
> > > Has anyone come across this issue?
> > >
> >
> > What is rendering? Unprocessed JSP source?
> >
> > Dave
> >
> >
> > ---------------------------------------------------------------------
> > To unsubscribe, e-mail: user-unsubscribe@struts.apache.org
> > For additional commands, e-mail: user-help@struts.apache.org
> >
> >
>
>
> --
> e: davelnewton@gmail.com
> m: 908-380-8699
> s: davelnewton_skype
> t: @dave_newton <https://twitter.com/dave_newton>
> b: Bucky Bits <http://buckybits.blogspot.com/>
> g: davelnewton <https://github.com/davelnewton>
> so: Dave Newton <http://stackoverflow.com/users/438992/dave-newton>
>
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: user-unsubscribe@struts.apache.org
> For additional commands, e-mail: user-help@struts.apache.org
>
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: user-unsubscribe@struts.apache.org
> For additional commands, e-mail: user-help@struts.apache.org
>
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: user-unsubscribe@struts.apache.org
> For additional commands, e-mail: user-help@struts.apache.org
>
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: user-unsubscribe@struts.apache.org
> For additional commands, e-mail: user-help@struts.apache.org
>
>


-- 
e: davelnewton@gmail.com
m: 908-380-8699
s: davelnewton_skype
t: @dave_newton <https://twitter.com/dave_newton>
b: Bucky Bits <http://buckybits.blogspot.com/>
g: davelnewton <https://github.com/davelnewton>
so: Dave Newton <http://stackoverflow.com/users/438992/dave-newton>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message