struts-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Alvin Chew <alvincks...@gmail.com>
Subject Re: maven upgrading
Date Fri, 05 Jul 2013 12:41:55 GMT
Not sure if i understand correctly, hope below help !

Declare an exact version (will always resolve to 1.0.1):

<version>[1.0.1]</version>

Declare an explicit version (will always resolve to 1.0.1 unless a
collision occurs, when Maven will select a matching version):

<version>1.0.1</version>

Declare a version range for all 1.x (will currently resolve to 1.1.1):

<version>[1.0.0,2.0.0)</version>

Declare an open-ended version range (will resolve to 2.0.0):

<version>[1.0.0,)</version>

Declare the version as LATEST (will resolve to 2.0.0):

<version>LATEST</version>

Declare the version as RELEASE (will resolve to 1.1.1):

<version>RELEASE</version>




On Fri, Jul 5, 2013 at 4:46 PM, Greg Huber <gregh3269@gmail.com> wrote:

> Hello,
>
> I have recently moved over to maven, so this may be a bit of a dumb
> question, when I  change my version to 2.3.15 it wants to add to the build
> all previous jar versions?
>
> /target/events/WEB-INF/lib/struts2-core-2.3.14.2.jar
> /target/events/WEB-INF/lib/struts2-core-2.3.14.jar
> /target/events/WEB-INF/lib/struts2-core-2.3.15.jar
> /target/events/WEB-INF/lib/struts2-javatemplates-plugin-2.3.14.2.jar
> /target/events/WEB-INF/lib/struts2-javatemplates-plugin-2.3.14.jar
> /target/events/WEB-INF/lib/struts2-javatemplates-plugin-2.3.15.jar
> /target/events/WEB-INF/lib/struts2-spring-plugin-2.3.14.2.jar
> /target/events/WEB-INF/lib/struts2-spring-plugin-2.3.14.jar
> /target/events/WEB-INF/lib/struts2-spring-plugin-2.3.15.jar
> /target/events/WEB-INF/lib/struts2-tiles-plugin-2.3.14.2.jar
> /target/events/WEB-INF/lib/struts2-tiles-plugin-2.3.14.jar
> /target/events/WEB-INF/lib/struts2-tiles-plugin-2.3.15.jar
> /target/events/WEB-INF/lib/xwork-core-2.3.14.2.jar
> /target/events/WEB-INF/lib/xwork-core-2.3.14.jar
> /target/events/WEB-INF/lib/xwork-core-2.3.15.jar
>
>
> Is there something I have to do to only use the latest version?
>
> <org.apache.struts.version>2.3.15</org.apache.struts.version>
> <dependency>
>             <groupId>org.apache.struts</groupId>
>             <artifactId>struts2-core</artifactId>
>             <version>${org.apache.struts.version}</version>
>             <exclusions>
>                 <exclusion>
>                     <artifactId>asm-commons</artifactId>
>                     <groupId>asm</groupId>
>                 </exclusion>
>                 <exclusion>
>                     <artifactId>asm</artifactId>
>                     <groupId>asm</groupId>
>                 </exclusion>
>                 <exclusion>
>                     <artifactId>javassist</artifactId>
>                     <groupId>javassist</groupId>
>                 </exclusion>
>             </exclusions>
>         </dependency>
>
>         <dependency>
>             <groupId>org.apache.struts</groupId>
>             <artifactId>struts2-tiles-plugin</artifactId>
>             <version>${org.apache.struts.version}</version>
>         </dependency>
>
>         <dependency>
>             <groupId>org.apache.struts</groupId>
>             <artifactId>struts2-spring-plugin</artifactId>
>             <version>${org.apache.struts.version}</version>
>         </dependency>
>
>         <dependency>
>             <groupId>org.apache.struts</groupId>
>             <artifactId>struts2-javatemplates-plugin</artifactId>
>             <version>${org.apache.struts.version}</version>
>         </dependency>
>
> Cheers Greg
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message