struts-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Fredrik Andersson <>
Subject Is this a createclassloader issue - HTTP Status 404 - result 'null' not found
Date Fri, 01 Nov 2013 21:02:57 GMT
Hello guys!


I have bought some space at a webhotel saying that it supports application that uses struts.

But when I enter a link like  <a href="login.action" >Log in</a> from my index.jsp
I just get:


HTTP Status 404 - result 'null' not found
    type Status report
    message result 'null' not found
    description The requested resource (result 'null' not found) is not available.

The webhotel uses a Tomcat fronted by a Apache. At the webhotel I have add a mapping like
"/*" that according to theres doc should forwarding all request to the Tomcat.


I first developed my site at home where it of course works fine in a similar environment (tomcat
fronted by a apache). At my first attempt to deploy it at the webhotel I got this error. Unfortenately
I can not see all logs my self, but the support at the webhotel told me that my app tried
to do some "createclassloader" and that is not allowed for me.


So in my hunt to find out why this createclassloader-issue derives from I have stripped the
site down to just a simple hello-world-app similar like this:
(My app is supposed to be run as the default app so my.)


But I still get the same error.


I found this post:


Is the "createclassloader"-issue coming from struts? Does it sounds like this might be something
that stuts needs to do?


What do you think guys could I facing the same problem? Is this a security-setting-problem?
I do not think I got the privileges to change security-settings at the webhotel according
to what the support first told me. Is there some other way to solve this? 


Else I think that this "product"/"type_of_account" at the webhotel promise to much. If struts
need to do the "createclassloader"-thing I doubt there will ever work to run a struts-app
or what do you think guys?


I also post some other info in this mail that might be of interest if you guys do not think
I'm on the right track.


In my Apache httpd.con I have set this (that I guess is the same mapping that I have done
at the webhotel) 
JkMount  /* worker1


In my web.xml


At the webhotel I have edit the context.xml.default to:
    <?xml version="1.0" encoding="ISO-8859-1"?>
    <Context path="" />


I have also added a context.xml like (that should overide the context.xml.default):
    <?xml version="1.0" encoding="ISO-8859-1"?>
    <Context path="" override="true" />

In my struts.xml i got this:

    <package name="basicstruts2" namespace="/" extends="struts-default">
        <action name="login">

        <action name="welcome" class="se.myapp.WelcomeUserAction">
            <result name="SUCCESS">/welcome.jsp</result>


And my index.jsp looks like below, and that renders out fine but when I click the link I get
the error above:
    <%@page import="se.myapp.WelcomeUserAction"%>
    <%@ page contentType="text/html; charset=UTF-8"%>
    <%@ taglib prefix="s" uri="/struts-tags"%>
        <body bgcolor="#FF9900">
            <h1>Site is under construction</h1>

            <a href="login.action" >Log in</a>
            <%=new java.util.Date().toString()%>


All this works fine at home.

So if you guys got any ideas or where to look for more info, please let me know.


Best regards




  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message