struts-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From John Patrick <nhoj.patr...@gmail.com>
Subject Re: Struts2 namespace confusion
Date Sat, 24 May 2014 15:34:56 GMT
Not seen this happen myself, what struts jar's do you have as it might be
something like the convention plugin...

If your using maven then it might be useful for others to include what
specific maven dependencies your including so potentially someone else can
try using the exact same jars.

John



On 24 May 2014 15:28, Matt Williams <mattwms1998cce@yahoo.com> wrote:

> Hello,
> I have been using struts 2.1.8 for a while and last night noticed an issue
> with mapping actions working with any url.
>
> For instance in the struts.xml file:
> - I have a package with a namespace of "/employee".
> - Within the package, I have an action mapping "search"
> - The webapp name is "TestWeb".
>
> So to access this page, I can go to:
> http://localhost:8080/TestWeb/employee/search.action and this works.
> However, if anything is added to the URL after the namespace such as:
> http://localhost:8080/TestWeb/employee/someExtraText/search.action the
> page still loads.
>
> Why does this happen?
>
>
> Reading the struts documentation
> (http://struts.apache.org/release/2.1.x/docs/namespace-configuration.html)
> would make me assume that it should search the "/employee/someExtraText"
> namespace...not find it, so then it should fall back to the default ""
> namespace...not find it...then display no action mapping found.
>
>
> Any insight? Thanks!
>
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: user-unsubscribe@struts.apache.org
> For additional commands, e-mail: user-help@struts.apache.org
>
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message