struts-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jim Anderson <jim_ander...@jjajava.com>
Subject Re: hello world is giving me a stack trace.
Date Sat, 12 Jul 2014 20:18:04 GMT


To all those who helped on this problem, my sincere thanks. It is now
resolved.

Resolution: Upgrade to tomcat7.

Jim A.

On 07/09/2014 07:26 AM, Martin Gainty wrote:
> MG>can you repost the Stacktrace in a followup email
> MG>thanks
>
> > Date: Tue, 8 Jul 2014 20:52:24 -0700
> > Subject: Re: hello world is giving me a stack trace.
> > From: haoniukun@gmail.com
> > To: jim_anderson@jjajava.com
> > CC: user@struts.apache.org
> >
> > Don't know why. I suspect you have a class name conflict somewhere
> in your
> > environment.
> >
> >
> > On Tue, Jul 8, 2014 at 6:15 PM, Jim Anderon <jim_anderson@jjajava.com>
> > wrote:
> >
> > >
> > > I am attaching the struts.xml file. This is the struts.xml file
> that came
> > > with the tutorial example. I have not
> > > edited it at all.
> > >
> > > I realize the stack track indicates the program failed in the
> struts.xml
> > > file, but I assume that
> > > for most people running the example, this example works. I suspect
> that
> > > the this code makes assumptions
> > > about the environment and that my environment does not meet all of the
> > > assumptions. I have no idea where
> > > to look for the root cause at this point.
> > >
> > > Jim
> > >
> > >
> > > On 07/08/2014 05:12 PM, Kun Niu wrote:
> > >
> > > The backtrace already told you. There's a classcast exception in your
> > > struts.xml file.
> > > You need to at least add your struts.xml file.
> > >
> > >
> > > On Tue, Jul 8, 2014 at 12:47 PM, Jim Anderon
> <jim_anderson@jjajava.com>
> > > wrote:
> > >
> > >>
> > >> Hi,
> > >>
> > >> I'm trying to learn about struts and I have been trying to run the
> > >> tutorials. The example, 'basic struts', runs ok in my
> > >> environment. But when I run 'hello_world', I get a stack trace,
> which I
> > >> will attach to this email.
> > >>
> > >> I'm running on Crunchbang linux, a Debian deriviative, and I'm using
> > >> tomcat6 as my server, with Struts 2.3.16.3.
> > >>
> > >> I was having trouble getting the example to run on my machine. I
> finally
> > >> got it to run successfully once. Every run
> > >> after that has given me a stacktrace. I figured that I might have
> messed
> > >> up the code in my work space, so I removed
> > >> everything, re-installed the hello_world directory and then
> rebuilt using
> > >> 'mvn clean package', which ran
> > >> successfully. I tried installing the war file both manually and
> using the
> > >> tomcat manager and got the same results
> > >> in either case.
> > >>
> > >> I am searching the internet for a similar stacktrace, but have
> not found
> > >> it yet. Has anyone on the mailing list
> > >> seen a similar problem before?
> > >>
> > >> Regards,
> > >> Jim Anderson
> > >>
> > >>
> > >> ---------------------------------------------------------------------
> > >> To unsubscribe, e-mail: user-unsubscribe@struts.apache.org
> > >> For additional commands, e-mail: user-help@struts.apache.org
> > >>
> > >
> > >
> > >
> > > --
> > > 牛坤
> > > MSN:haoniukun@hotmail.com
> > >
> > >
> > >
> >
> >
> > --
> > 牛坤
> > MSN:haoniukun@hotmail.com


Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message