struts-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Ken McWilliams <ken.mcwilli...@gmail.com>
Subject Re: Upgrading from Struts 2.0 to 2.3.16
Date Wed, 16 Jul 2014 17:18:04 GMT
I'd be of the mind that during the upgrade that some how the resource:
'/mmr/jsp/templates/layout_
admin_window.jsp' and other folders were somehow moved and that
"org.apache.tiles.
TilesException: ServletException including path" is perfectly accurate.
Generally you don't want templates to be exposed and the include path
should start with "/WEB-INF/..."

If in doubt about dependencies follow one of the several struts2-tiles
integration threads using maven. I'm assuming you are not using maven. Then
copy the required dependencies into your project.

On Tue, Jul 15, 2014 at 11:42 PM, Sreekanth S. Nair <
sreekanth.nair@egovernments.org> wrote:

> > Caused by: java.lang.NoSuchMethodError:
> > org.apache.tiles.jsp.taglib.InsertAttributeTag.doFinally()
> >
>
> Must be tiles not compatible
>
> --
> Thanks & Regards
>
> Sreekanth S Nair
> Java Developer
> -------------------------------------------
> eGovernments Foundation <http://www.egovernments.org>
> Ph : 9980078913
> -------------------------------------------
> <http://in.linkedin.com/pub/sreekanth-s-nair/b/946/5a0/>
> <https://github.com/sreekanthsnair>   <sreekanthsnair@hotmail.co.uk>
> <sreekanthsnyr@gmail.com>
> -------------------------------------------
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message