struts-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Ralph Cook <rc...@pobox.com>
Subject Re: Can't use 'expand' on struts 2 debug browser output
Date Thu, 14 Aug 2014 12:26:03 GMT
Thanks -- the tar file doesn't look right (I downloaded it using the 
'snapshot' link on 
https://git-wip-us.apache.org/repos/asf?p=struts.git;h=90eb79a ).  It 
has 60-80 empty directories and over 1600 files in the root, then a more 
normal-looking tree in the struts-90eb79a directory.  I don't need this 
immediately, I'll watch the project for a future release.

rc

On 8/14/2014 1:42 AM, Lukasz Lenart wrote:
> 2014-08-14 1:09 GMT+02:00 Ralph Cook <rcook@pobox.com>:
>> I am working with the basic_struts example application, attempting to study
>> the debugging tools in Struts 2. I have done the following:
>>
>> put <s:head /> within my <head> tags
>> put struts2-dojo-plugin in my maven dependencies
>> put "?debug=browser" at the end of a link to be clicked on
>>
>> When I click on the link, it displays the debug page, with a number of links
>> labelled "Expand".  No errors show up in the console.  When I hover over the
>> "Expand" links, they show "javascript://nop/"; when I click on them, I can't
>> see that anything happens. I tried a number of different ones.
>>
>> When I look at the source for the page, I can see that there is javascript
>> to execute when the Expand link is clicked. I attempted to enter the Chrome
>> debugger, but I don't know how to open the source so that I can set a
>> breakpoint.
>>
>> So, does someone know something else to do that a newbie might forget? Or
>> can someone please point me to some kind of troubleshooting method?
>>
>> rc
>
> There was few issue around (Dojo plugin is broken after migrating to
> Git, Debug console had some issues) so I migrate Debug Console to
> jQuery and fixed it
>
> https://issues.apache.org/jira/browse/WW-4322
>
> You can try the latest snapshot
>
>
> Regards
>

---------------------------------------------------------------------
To unsubscribe, e-mail: user-unsubscribe@struts.apache.org
For additional commands, e-mail: user-help@struts.apache.org


Mime
View raw message