struts-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Martin Gainty <mgai...@hotmail.com>
Subject RE: S:url and s:param and character encoding
Date Sat, 30 Aug 2014 18:37:10 GMT
Struts URL modificada por request_locale de 'es' va a refeerncia el archivo de propiedades
<s:url id="indexES" namespace="/" action="locale" >
      <s:param name="request_locale" >es</s:param>
</s:url>

<!-- las siguientes referencias de struts tiraría el contenido de esta GLOBAL_ES.properties
-->
global.name = Nombre de usuario
global.age = Edad
global.submit = Presentar
global.heading = seleccionar la configuracion regional
global.success = Autenticado correctamente

   <s:a href="%{indexES}" >Español</s:a>
   <s:form action="empinfo" method="post" namespace="/">
      <s:textfield name="name" key="global.name" size="20" />
      <s:textfield name="age" key="global.age" size="20" />
      <s:submit name="submit" key="global.submit" />
   </s:form>
                                                                                         
       <-- ¿no trabaja para ti ? -->

> Subject: S:url and s:param and character encoding
> From: miguel@almeida.at
> To: user@struts.apache.org
> Date: Fri, 29 Aug 2014 17:11:11 +0100
> 
> I had an issue recently with a download action not finding the
> corresponding file and you might be able to help me with it. The
> filename (on disk) was "Calendário" ("á" is the focus here).
> 
> I am using the following s:url (Calendário is within the variable
> #answer):
> 
> 		 		<s:url encode="true" var="downloadUrl" action="Filedownload">
> 					<s:param name="answer.id">${entityId}</s:param>
> 					<s:param name="fileName"><s:property value="%{#answer}"/></s:param>
> 				</s:url>
> 				<s:a theme="simple" href="%{downloadUrl}"><s:property
> value="%{#answer}"/></s:a> 
> 
> If I use a plain-old <a> and s:properties I get the normal behaviour:
> 
> 				<a href="Filedownload.action?answer.id=<s:property
> value="%{#entityId}"/>&fileName=<s:property
> value="%{#answer}"/>"><s:property value="%{#answer}"/></a>
> 
> Is there something missing from s:url?
> I also found https://issues.apache.org/jira/browse/WW-2414 which seems
> to mention something similar, but marked as solved in 2.0.x.
> 
> Cheers,
> 
> Miguel
 		 	   		  
Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message