struts-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Luis Limas <luiscl...@hotmail.com>
Subject Re: Struts missing parameters
Date Thu, 07 Aug 2014 15:04:59 GMT
On 07/08/2014 12:52 a. m., Lukasz Lenart wrote:
> 2014-08-04 18:37 GMT+02:00 Luis Limas <luiscla27@hotmail.com>:
>>       =============================================
>>       POST-DATA:
>>       =============================================
>>
>> {"params":[*{"author":{"id":302},"autoProm":0,"autorizationPool":null,"blockedBy":null,"blockedByName":null,"businessUnit":null,"code":"","creationDate":"2014-07-30T12:36:37","deleted":0,"department":{"id":"13"},"description":"BITACORA
>>     DE REVISION SEMANAL DE MOLINOS GLENN
>>
>> MILL","document":null,"documentCode":"FFQ-043","documentType":{"code":"FORMATOS","deleted":0,"description":"FORMATOS","id":11,"isRetainable":1,"moduleId":0,"saveHandle":null,"status":4,"value":"11"},"fileId":12820,"flujo":{"id":"24"},"id":_41201_,"isBusy":null,"nodo":{"id":3575},"organizationalUnit":null,"reazon":"FORMALIDAD
>>     DE LA BITACORA EN UN REGISTRO
>>
>> CONTROLADO","requestLogList":[],"retentionText":"3","retentionTime":1,"saveHandle":null,"status":3,"storagePlaceId":"1","timeToFreeMinutes":null,"type":1,"verificationList":[],"version":"1","tipoSolicitud":1}*],"method":"verifyRequestSMD","id":3}
>>       =============================================
>>
>>
>> Previews data was printed at a Filter i've made for debugging purposes, it
>> runs before any struts interceptor (RequestBuffer.java) (the failure happens
>> with and without my filter)
>>
>> The stack trace shows an error inside my application because the red-id
>> parameter didn't made it to my function called "HQLT_findById", actually a
>> null was sent there
> I don't see "red-id" in POST-DATA section
>
>
> Regards
The mailing list is removing color/bold/italic format. the following 
json-attribute its supposed to have red font color

"id":_41201_

Thanks for the reply Lukasz, the main issue i am having it's that entity annotated with @MappedSuperClass
is not being correctly populated after JSONUtil.deserialize, the issue occurs randomly and
only "super" setters are the ones that are not being called,

Greetings,


---
Este mensaje no contiene virus ni malware porque la protección de avast! Antivirus está
activa.
http://www.avast.com


---------------------------------------------------------------------
To unsubscribe, e-mail: user-unsubscribe@struts.apache.org
For additional commands, e-mail: user-help@struts.apache.org


Mime
View raw message