struts-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Sreekanth S. Nair" <sreekanth.n...@egovernments.org>
Subject Re: Struts2 Not Working After Migrating from 2.3.15.1 to 2.3.20 in Wildfly server
Date Mon, 15 Dec 2014 07:09:51 GMT
Thanks a lot Lukasz... appreciate all your help on fixing this up. WARN :)

-- 
Thanks & Regards

Sreekanth S Nair
Java Developer
-------------------------------------------
eGovernments Foundation <http://www.egovernments.org>
Ph : 9980078913
-------------------------------------------
<http://in.linkedin.com/pub/sreekanth-s-nair/b/946/5a0/>
<https://github.com/sreekanthsnair>   <sreekanthsnair@hotmail.co.uk>
<sreekanthsnyr@gmail.com>
-------------------------------------------

On Mon, Dec 15, 2014 at 12:37 PM, Lukasz Lenart <lukaszlenart@apache.org>
wrote:
>
> 2014-12-15 7:57 GMT+01:00 Sreekanth S. Nair <
> sreekanth.nair@egovernments.org>:
> > Hi Lukasz,
> >                      :) i haven't intentionally added rest-plugin, that
> was
> > by mistake i have included and went clueless.
>
> That would have been my second question if you still have had problems ;-)
>
> >  I need one more help from you regarding custom struts.xml, can you
> kindly
> > tell me the struts.xml i have attached is correct ? i have removed the
> > excludeParam as you suggested in the earlier mail. Anything similar
> changes
> > ?
>
> <!-- Production Performance Environment Setting, Change to inverse
> value of the same in Development Environment -->
> <constant name="struts.devMode" value="true" />
> <constant name="struts.freemarker.templatesCache" value="true" />
> <constant name="struts.xslt.nocache" value="false" />
> <constant name="struts.ognl.logMissingProperties" value="true" />
> <constant name="struts.el.throwExceptionOnFailure" value="true" />
> <constant name="struts.ognl.enableExpressionCache" value="true" />
> <constant name="struts.serve.static" value="true" />
> <constant name="struts.i18n.reload" value="true" />
> <constant name="struts.configuration.xml.reload" value="true" />
> <constant name="struts.freemarker.beanwrapperCache" value="true" />
> <!-- Performance Environment Setting Ends -->
>
> why do you set all these to false in production? At least these two
> should be always set to true
> <constant name="struts.freemarker.templatesCache" value="true" />
> <constant name="struts.freemarker.beanwrapperCache" value="true" />
>
> The rest looks good, I have added a note to docs about accepted/excluded
> params
>
> https://cwiki.apache.org/confluence/display/WW/Security#Security-Accepted/Excludedpatterns
>
>
> Regards
> --
> Ɓukasz
> + 48 606 323 122 http://www.lenart.org.pl/
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: user-unsubscribe@struts.apache.org
> For additional commands, e-mail: user-help@struts.apache.org
>
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message