struts-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Yaragalla Muralidhar <yaragallamur...@gmail.com>
Subject validation problem
Date Thu, 25 Dec 2014 10:38:24 GMT
Hi i am having problem in turning on validations. I have written
"actionClass-validation.xml" file in the same package as action class.  but
the validations are not working. the following is my validation xml file.

<!DOCTYPE validators PUBLIC "-//Apache Struts//XWork Validator 1.0.3//EN"
        "http://struts.apache.org/dtds/xwork-validator-1.0.3.dtd">
<validators>

<field name="primaryDetails.branchId">
     <field-validator type="required">
       <message key="error.additional.details.passport.no">Could not find
error.additional.details.passport.no!</message>
     </field-validator>
     <field-validator type="regex">
          <param name="regex"><![CDATA[[1-9]{0,40}]]></param>
       <message key="error.additional.details.pancard.no">Could not find
error.additional.details.pancard.no</message>
     </field-validator>
</field>
 <field name="primaryDetails.patientName">
     <field-validator type="required">
       <message key="error.additional.details.passport.no">Could not find
error.additional.details.passport.no!</message>
     </field-validator>

</field>

</validators>

do i have to do something else to turn on validations?


*Thanks and Regards,*
Muralidhar Yaragalla.

*http://yaragalla.blogspot.in/ <http://yaragalla.blogspot.in/>*

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message