struts-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Gerald Scheetz <gsche...@yahoo.com>
Subject Re: Struts2 Not Working After Migrating from 2.3.15.1 to 2.3.20 in Wildfly server
Date Fri, 12 Dec 2014 16:56:25 GMT
Lukasz Lenart <lukaszlenart <at> apache.org> writes:



> 

> Can you try with 2.3.16.3 first?

> 

> 2014-12-12 15:30 GMT+01:00 Sreekanth S. Nair <sreekanth.nair <at> 
egovernments.org>:

> > Hi,

> >      Am facing a weird issue after upgrading strust2 from  2.3.15.1 to

> > 2.3.20 in Wildfly server. Its not giving any debug or any kind of trace

> > about what is happening, its just going to 404 page. I switched debug 
mode

> > in both struts config as well as in my server log but couldn't get a 
single

> > clue on what is happening. I'm using strust2-convention-plugin.

> > My action class name is HomepageAction and located inside

> > org.xyz.web.actions.common

> >

> > I'm accessing it by url

> > http://localhost:8080/ctxtpath/common/homepage.action

> >

> > The same setup is working perfectly in 2.3.15.1.....

> >

> > Anyone face similar issue ? any help would be appreciated.

> >

> > Thanks

> > Srikanth

> 



I had the same problem this morning after updating just the struts2 and 
xwork jar files.



I updated the asm, asm-commons, asm-tree, and commons-lang3 jar files to 
those found in the struts-2.3.20-lib.zip file and the problem went away.



Hope this helps.








---------------------------------------------------------------------
To unsubscribe, e-mail: user-unsubscribe@struts.apache.org
For additional commands, e-mail: user-help@struts.apache.org


Mime
View raw message