struts-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Martin Gainty <mgai...@hotmail.com>
Subject RE: Issues with Tomcat 7.0.57 not loading ActionServlets
Date Mon, 25 May 2015 01:08:53 GMT
No Problem...that is what we are here for

Have a Productive Week Raj!
Martin Gainty 
______________________________________________ 
                                                                                         
          


> Date: Sat, 23 May 2015 16:05:55 -0500
> Subject: Re: Issues with Tomcat 7.0.57 not loading ActionServlets
> From: bsudershanraj@gmail.com
> To: user@struts.apache.org
> 
> Hi Martin,
> The dtd for validations.xml, validator-rules.xml and struts-config.xml are
> not same and that was causing this issue. However, this is fixed after made
> it same for all.
> 
> Thanks a lot Martin for all your help
> 
> -Raj
> 
> 
> 
> On Sat, May 23, 2015 at 12:07 PM, Raj <bsudershanraj@gmail.com> wrote:
> 
> > Hi Martin,
> > I have verified tiles.jar file was not there under /WEB_INF/lib folder but
> > I have added *struts-tiles-1.3.10.jar *under /WEB_INF/lib folder and
> > still does not make any difference. Even the old application does not have
> > tiles.jar file. we just deployed the old application on the new tomcat
> > 7.0.57.
> >
> > Here is what we have in struts-config.xml
> >
> >   </action-mappings>
> >
> >   <message-resources    parameter="ApplicationResources"/>
> >
> >   <plug-in className="org.apache.struts.validator.ValidatorPlugIn">
> >
> >     <set-property  property="pathnames"
> >
> >     value="/WEB-INF/validator-rules.xml,/WEB-INF/validation.xml"/>
> >
> >   </plug-in>
> >
> > Here is what we have in web.xml
> >
> > <!-- Action Servlet Configuration -->
> >
> >    <servlet>
> >
> > <servlet-name>action</servlet-name>
> >
> > <servlet-class>org.apache.struts.action.ActionServlet</servlet-class>
> >
> > <init-param>
> >
> >  <param-name>config</param-name>
> >
> >  <param-value>/WEB-INF/struts-config.xml</param-value>
> >
> > </init-param>
> >
> > <load-on-startup>1</load-on-startup>
> >
> >     </servlet>
> >
> >
> > we even tried your suggestion of removing the validator-rules.xml from the
> > struts-config.xml but of no use. The exception we are seeing is not giving
> > enough details. Is there any other way we can get more detail exceptions.
> >
> >
> > Thanks
> >
> > Raj
> >
> > On Thu, May 21, 2015 at 7:50 PM, Martin Gainty <mgainty@hotmail.com>
> > wrote:
> >
> >> If Maven is a Lamborghini ..then Ant is a Yugo
> >> You can drive to end of the block with Yugo if you dont mind repairing it
> >> every few feet
> >> Once you start driving your builds with Maven I guarantee you *wont* go
> >> back to Ant
> >>
> >> *keep us apprised*
> >> Martin
> >> ______________________________________________
> >>
> >>
> >>
> >> > Subject: Re: Issues with Tomcat 7.0.57 not loading ActionServlets
> >> > From: bsudershanraj@gmail.com
> >> > Date: Tue, 19 May 2015 11:28:48 -0500
> >> > To: user@struts.apache.org
> >> >
> >> > Hi Martin,
> >> > Thanks for your quick response
> >> >
> >> > We are not using Maven. It's ant build and have got no documentation. I
> >> have just started supporting this application with no proper documentation.
> >> > I will check if tiles.jar file exists under lib folder and get back to
> >> you after working on your suggestions
> >> >
> >> > Thanks
> >> > Raj
> >> >
> >> > Sent from my iPhone
> >> >
> >> > > On May 19, 2015, at 5:33 AM, Martin Gainty <mgainty@hotmail.com>
> >> wrote:
> >> > >
> >> > > please confirm url,connection,developerConnection entries are pointed
> >> to struts1 in <scm> section your pom.xml:
> >> > >
> >> > >  <scm>
> >> > >       <connection>scm:svn:
> >> http://svn.apache.org/repos/asf/struts/struts1/trunk</connection>
> >> > >       <developerConnection>scm:svn:
> >> https://svn.apache.org/repos/asf/struts/struts1/trunk
> >> </developerConnection>
> >> > >       <url>http://svn.apache.org/viewcvs.cgi/struts/struts1/trunk
> >> </url>
> >> > >    </scm>
> >> > >
> >> > > please confirm the commons-validator dependency is present in pom.xml:
> >> > >   <dependency>
> >> > >                <groupId>commons-validator</groupId>
> >> > >                <artifactId>commons-validator</artifactId>
> >> > >                <version>1.3.1</version>
> >> > >                <exclusions>
> >> > >                    <exclusion>
> >> > >                        <groupId>xml-apis</groupId>
> >> > >                        <artifactId>xml-apis</artifactId>
> >> > >                    </exclusion>
> >> > >                </exclusions>
> >> > >            </dependency>
> >> > >
> >> > > please confirm  validatorValidatorPlugin exists in
> >> /WEB-INF/struts-config.xml e.g
> >> > >
> >> > > <plug-in className="org.apache.struts.validator.ValidatorPlugIn">
> >> > >        <set-property property="pathnames"
> >> > >
> >> value="/org/apache/struts/validator/validator-rules.xml,
> >> > >                             /WEB-INF/validation.xml"/>
> >> > >      </plug-in>
> >> > >
> >> > > please confirm you added add tiles.jar to WEB-INF/lib
> >> > >
> >> > > finally when something goes awry I usually comment out the
> >> <validator-rules,xml> configuration and bring in one validator entry at
a
> >> time
> >> > > <!---
> >> > > <validator...>
> >> > > <validator..>
> >> > > -->
> >> > > if Servlet still wont load then you may have a misconfigure in
> >> struts-config.xml or even possibly misconfig in web.xml
> >> > > or possibly omitted required parameter in pom.xml
> >> > >
> >> > > if Servlet DOES load then you can enable each of the validators in
> >> validator-rules.xml one at a time
> >> > >
> >> > > Let us know how it goes,
> >> > > Martin
> >> > > ______________________________________________
> >> > >
> >> > >> Subject: Re: Issues with Tomcat 7.0.57 not loading ActionServlets
> >> > >> From: bsudershanraj@gmail.com
> >> > >> Date: Mon, 18 May 2015 17:40:12 -0500
> >> > >> To: user@struts.apache.org
> >> > >>
> >> > >> Yes Martin,
> >> > >> That file does exists in that folder.
> >> > >>
> >> > >> Thanks
> >> > >> Raj
> >> > >>
> >> > >> Sent from my iPhone
> >> > >>
> >> > >>> On May 16, 2015, at 7:54 PM, Martin Gainty <mgainty@hotmail.com>
> >> wrote:
> >> > >>>
> >> > >>> Raj-
> >> > >>>
> >> > >>> did you check for the existence of
> >> > >>> /WEB-INF/validator-rules.xmlin
> >> $TOMCAT_HOME/webapps/NameOfYourWebappGoesHere
> >> > >>> ?
> >> > >>> Martin
> >> > >>> ______________________________________________
> >> > >>>
> >> > >>>
> >> > >>>
> >> > >>>> Date: Wed, 6 May 2015 20:29:34 -0500
> >> > >>>> Subject: Issues with Tomcat 7.0.57 not loading ActionServlets
> >> > >>>> From: bsudershanraj@gmail.com
> >> > >>>> To: user@struts.apache.org
> >> > >>>>
> >> > >>>> I upgraded my application from tomcat 5.5.15, JDK 1.5,
Struts 1.1
> >> on Debian
> >> > >>>> 2.6.32 to
> >> > >>>> tomcat 7.0.57, JDK 1.6, struts 1.1 on ubuntu14.04 and
Action
> >> Servlets are
> >> > >>>> not loading.
> >> > >>>> I am thinking of this is something to do with version
conflict.
> >> Please let
> >> > >>>> me know what I am missing.
> >> > >>>>
> >> > >>>> Below is the error
> >> > >>>>
> >> > >>>> Apr 24, 2015 9:00:20 PM
> >> org.apache.catalina.core.ApplicationContext log
> >> > >>>>
> >> > >>>> INFO: org.apache.webapp.balancer.BalancerFilter: init():
ruleChain:
> >> > >>>> [org.apache.webapp.balancer.RuleChain: RoundRobinRule@643fd34a]
> >> > >>>>
> >> > >>>> Apr 24, 2015 9:00:20 PM
> >> org.apache.catalina.core.ApplicationContext log
> >> > >>>>
> >> > >>>> INFO: Marking servlet action as unavailable
> >> > >>>>
> >> > >>>> Apr 24, 2015 9:00:20 PM org.apache.catalina.core.StandardContext
> >> > >>>> loadOnStartup
> >> > >>>>
> >> > >>>> SEVERE: Servlet  threw load() exception
> >> > >>>>
> >> > >>>> javax.servlet.UnavailableException: Cannot load a validator
> >> resource from
> >> > >>>> '/WEB-INF/validator-rules.xml'
> >> > >>>>
> >> > >>>> at
> >> > >>>>
> >> org.apache.struts.validator.ValidatorPlugIn.init(ValidatorPlugIn.java:174)
> >> > >>>>
> >> > >>>> at
> >> > >>>> org.apache.struts.action.ActionServlet.initModulePlugIns(
> >> > >>>> ActionServlet.java:839)
> >> > >>>>
> >> > >>>> at
> >> org.apache.struts.action.ActionServlet.init(ActionServlet.java:332)
> >> > >>>>
> >> > >>>> at javax.servlet.GenericServlet.init(GenericServlet.java:158)
> >> > >>>>
> >> > >>>> at
> >> > >>>> org.apache.catalina.core.StandardWrapper.initServlet(
> >> > >>>> StandardWrapper.java:1284)
> >> > >>>>
> >> > >>>> at
> >> > >>>> org.apache.catalina.core.StandardWrapper.loadServlet(
> >> > >>>> StandardWrapper.java:1197)
> >> > >>>>
> >> > >>>> at
> >> org.apache.catalina.core.StandardWrapper.load(StandardWrapper.java:1087)
> >> > >>>>
> >> > >>>> at
> >> > >>>> org.apache.catalina.core.StandardContext.loadOnStartup(
> >> > >>>> StandardContext.java:5231)
> >> > >>>>
> >> > >>>> at
> >> > >>>> org.apache.catalina.core.StandardContext.startInternal(
> >> > >>>> StandardContext.java:5518)
> >> > >>>>
> >> > >>>> at
> >> org.apache.catalina.util.LifecycleBase.start(LifecycleBase.java:150)
> >> > >>>>
> >> > >>>> at
> >> > >>>> org.apache.catalina.core.ContainerBase.addChildInternal(
> >> > >>>> ContainerBase.java:901)
> >> > >>>>
> >> > >>>> at
> >> org.apache.catalina.core.ContainerBase.addChild(ContainerBase.java:877)
> >> > >>>>
> >> > >>>> at
> >> org.apache.catalina.core.StandardHost.addChild(StandardHost.java:649)
> >> > >>>>
> >> > >>>> at
> >> org.apache.catalina.startup.HostConfig.deployWAR(HostConfig.java:1081)
> >> > >>>>
> >> > >>>> at
> >> > >>>>
> >> org.apache.catalina.startup.HostConfig$DeployWar.run(HostConfig.java:1877)
> >> > >>>>
> >> > >>>> at
> >> java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:471)
> >> > >>>>
> >> > >>>> at
> >> java.util.concurrent.FutureTask$Sync.innerRun(FutureTask.java:334)
> >> > >>>>
> >> > >>>> at java.util.concurrent.FutureTask.run(FutureTask.java:166)
> >> > >>>>
> >> > >>>> at
> >> > >>>> java.util.concurrent.ThreadPoolExecutor.runWorker(
> >> > >>>> ThreadPoolExecutor.java:1146)
> >> > >>>>
> >> > >>>> at
> >> > >>>> java.util.concurrent.ThreadPoolExecutor$Worker.run(
> >> > >>>> ThreadPoolExecutor.java:615)
> >> > >>>>
> >> > >>>> at java.lang.Thread.run(Thread.java:701)
> >> > >>>>
> >> > >>>> Thanks
> >> > >>
> >> > >> ---------------------------------------------------------------------
> >> > >> To unsubscribe, e-mail: user-unsubscribe@struts.apache.org
> >> > >> For additional commands, e-mail: user-help@struts.apache.org
> >> > >
> >> >
> >> > ---------------------------------------------------------------------
> >> > To unsubscribe, e-mail: user-unsubscribe@struts.apache.org
> >> > For additional commands, e-mail: user-help@struts.apache.org
> >> >
> >>
> >>
> >
> >
 		 	   		  
Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message