struts-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Lukasz Lenart <lukaszlen...@apache.org>
Subject Re: [S2] Trouble getting started
Date Mon, 28 Sep 2015 06:49:28 GMT
2015-09-27 18:02 GMT+02:00 Christopher Schultz <chris@christopherschultz.net>:
>> The best option is to use one of Maven's archetypes
>>
>> http://struts.apache.org/docs/struts-2-maven-archetypes.html#Struts2Ma
> venArchetypes-Quickstart
>
> Yeah...
>>
> I was trying to avoid using Maven, which to me has too much
> opaque hand-waving that I neither understand nor control.
>
> I have what I believe is a fairly simple test app at this point. I
> should be able to get it to work without resorting to drastic measures :
> )

Maven isn't that bad and it's a good time to learn S2 and Maven together ;-)

>> Wrong DTD, please use the latest one
>>
>> <!DOCTYPE struts PUBLIC "-//Apache Software Foundation//DTD Struts
>> Configuration 2.3//EN"
>> "http://struts.apache.org/dtds/struts-2.3.dtd">
>
> Yep, I updated to this one this morning, after trying to find out the
> default value for the <result> "name" attribute. Still no change.

"name" isn't mandatory, it will fallback to "success" if not set. But
maybe you are right and we should define the default value.

>> Are you sure that you have deployed your app as ROOT.war to
>> $TOMCAT_HOME/webapps ?
>
> It's not deployed as a WAR, but as webapps/ROOT (exploded WAR directory)

Could you build a war and deploy it manually?


Regards
-- 
Ɓukasz
+ 48 606 323 122 http://www.lenart.org.pl/

---------------------------------------------------------------------
To unsubscribe, e-mail: user-unsubscribe@struts.apache.org
For additional commands, e-mail: user-help@struts.apache.org


Mime
View raw message