struts-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Tamás Barta <bartata...@gmail.com>
Subject Re: Struts 2.5.12
Date Fri, 14 Jul 2017 07:36:51 GMT
Yes.

The very strange thing I don't understand are the following lines in the
stacktrace:

07:33:09,799 ERROR [stderr] (ServerService Thread Pool -- 99)  at
com.opensymphony.xwork2.inject.ContainerBuilder.constant(ContainerBuilder.java:398)
07:33:09,800 ERROR [stderr] (ServerService Thread Pool -- 99)  at
com.opensymphony.xwork2.config.impl.DefaultConfiguration.createBootstrapContainer(DefaultConfiguration.java:284)

The 284. line of DefaultConfiguration is builder.create(true), but I can't
see it in the stacktrace, the next line is a "constant" call.
I see the same strange thing when I debug. I put a breakpoint at
DefaultConfiguration:284 and when I enter method "create" I will be right
at "constant" in Eclipse. I don't understand how can it happen.
It happens even if I rebuild core jar and uses the new one.


On Fri, Jul 14, 2017 at 9:35 AM, Lukasz Lenart <lukaszlenart@apache.org>
wrote:

> 2017-07-14 9:25 GMT+02:00 Tamás Barta <bartatamas@gmail.com>:
> > I updated them, I updated all the jars.
>
> Hmm... is it the same exception as on the beginning of this conversation?
>
>
> Regards
> --
> Łukasz
> + 48 606 323 122 http://www.lenart.org.pl/
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: user-unsubscribe@struts.apache.org
> For additional commands, e-mail: user-help@struts.apache.org
>
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message