struts-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Lukasz Lenart <lukaszlen...@apache.org>
Subject Re: Struts 2.5.12
Date Fri, 14 Jul 2017 07:44:52 GMT
2017-07-14 9:36 GMT+02:00 Tamás Barta <bartatamas@gmail.com>:
> Yes.
>
> The very strange thing I don't understand are the following lines in the
> stacktrace:
>
> 07:33:09,799 ERROR [stderr] (ServerService Thread Pool -- 99)  at
> com.opensymphony.xwork2.inject.ContainerBuilder.constant(ContainerBuilder.java:398)
> 07:33:09,800 ERROR [stderr] (ServerService Thread Pool -- 99)  at
> com.opensymphony.xwork2.config.impl.DefaultConfiguration.createBootstrapContainer(DefaultConfiguration.java:284)
>
> The 284. line of DefaultConfiguration is builder.create(true), but I can't
> see it in the stacktrace, the next line is a "constant" call.
> I see the same strange thing when I debug. I put a breakpoint at
> DefaultConfiguration:284 and when I enter method "create" I will be right
> at "constant" in Eclipse. I don't understand how can it happen.
> It happens even if I rebuild core jar and uses the new one.

That's why I have asked about duplicated jars as this happens to me
when using SNAPSHOT versions locally (two same SNAPSHOTs have
different timestamps inside name). Or JRebel still uses an old version
of the Core


Regards
-- 
Łukasz
+ 48 606 323 122 http://www.lenart.org.pl/

---------------------------------------------------------------------
To unsubscribe, e-mail: user-unsubscribe@struts.apache.org
For additional commands, e-mail: user-help@struts.apache.org


Mime
View raw message