struts-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From fullmit...@lycos.com
Subject Re: CDI Plugin example does not work in 2.5.14.1
Date Mon, 22 Jan 2018 18:11:08 GMT
I am using Java 1.8.0_131-b11 on Windows 7, 64-bit for both building the 
app and running Weblogic.

I did some more experimenting. I tried removing CDI from my source code 
and the Maven pom.  I still get the error with a complete stripped down 
application (the only dependency being Struts), so CDI isn't at issue 
here.

The word from Oracle is that this problem appears to have been 
introduced into WLS 12.1.3 between the July 2016 and January 2018 
Critical Patch Updates (that is, Struts works with the earlier patch and 
does not work with the latter). I, of course, am running with the latest 
updates.
Thanks.


On 2018-01-21 14:32, Lukasz Lenart wrote:

> Ah, right :) We have moved this dependency directly under the
> Convention Plugin, so if you do not use it, there be no ASM jar.
> 
> What version of Java do you use to compile the project and what
> version is used to run the Weblogic?
> 
> Regards
> --
> Ɓukasz
> + 48 606 323 122 http://www.lenart.org.pl/
> 
> 2018-01-19 20:05 GMT+01:00  <fullmitten@lycos.com>: Interesting.  I 
> looked at the dependencies included with the struts2-core
> Maven artifact and it appears that ASM 5.2 is not there. Is this on 
> purpose?
> I see ASM is included in the lib file of the downloadable distribution 
> and
> in the WEB-INF/lib directory of the sample applications.  Needless to 
> say,
> since it isn't in the Maven dependency chain, it does not appear in my
> application.
> I tried adding ASM 5.2 to my pom, added some instructions to try to get
> Weblogic to prefer the packages in the web application over Weblogic's 
> own
> (don't know why that isn't the default behavior *shrug*) and got the 
> same
> failure.
> I tried deploying the same application to Tomcat 9 and it worked fine, 
> so it
> looks like either I'm configuring something wrong in Weblogic or 
> Weblogic
> has a problem. I've opened a support request with Oracle to see what 
> they
> think.
> Thanks!
> 
> On 2018-01-19 03:17, Lukasz Lenart wrote:
> 
> It's probably because we have switched to the latest ASM 5.2 version
> [1] but looks like Weblogic uses (repackaged one -
> "com.bea.objectweb.asm") an old version of ASM. I think you should
> request Oracle support for a solution, maybe they have a patch for the
> Weblogic or try to downgrade version used in Struts.
> 
> [1] https://issues.apache.org/jira/browse/WW-4826
> 
> 2018-01-18 17:01 GMT+01:00  <fullmitten@lycos.com>: On 1/18/2018 12:26 
> AM,
> fullmitten@lycos.com wrote:
> Caused By: java.lang.IllegalArgumentException
> at com.bea.objectweb.asm.ClassReader.<init>(Unknown Source)
> at com.bea.objectweb.asm.ClassReader.<init>(Unknown Source)
> at
> 
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: user-unsubscribe@struts.apache.org
> For additional commands, e-mail: user-help@struts.apache.org

---------------------------------------------------------------------
To unsubscribe, e-mail: user-unsubscribe@struts.apache.org
For additional commands, e-mail: user-help@struts.apache.org

---------------------------------------------------------------------
To unsubscribe, e-mail: user-unsubscribe@struts.apache.org
For additional commands, e-mail: user-help@struts.apache.org


Mime
View raw message