struts-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From user0707 <karthikeyan87.s...@gmail.com>
Subject Migrate from Struts2 from 2.3.34 to 2.3.35
Date Sat, 08 Sep 2018 21:20:53 GMT
I am working on upgrading struts from 2.3.34 to 2.3.35 and I all assumed it
will be fully backward compatible. 

Replaced following .jar which is marked as essential and while bringing up
WebApp in WAS, facing trouble with freemarker.jar
(freemarker/core/_Java8Impl.class). 

Code is currently compiled against JDK 1.6 and JRE - 1.7 and while
application is coming up facing below exception:

[9/8/18 16:41:42:398 EDT] 00000042 ecs           W
com.xxx.ws.ecs.internal.scan.context.impl.ScannerContextImpl scanJAR unable
to open input stream for resource freemarker/core/_Java8Impl.class in
archive WEB-INF/lib/freemarker-2.3.28.jar
                                 java.lang.IllegalArgumentException
	at org.objectweb.asm.ClassReader.<init>(Unknown Source)
	at org.objectweb.asm.ClassReader.<init>(Unknown Source)
	at org.objectweb.asm.ClassReader.<init>(Unknown Source)


Seems like this class and .jar is Build against JDK1.8 and will it be
problem for users below JDK/JRE 1.8 ?

I see this version of freemarker is marked as dependency in version notes of
struts, but can I continue to use freemarker-2.3.22.jar against struts
2.3.35?

Is there any way to avoid scanning of this .jar alone or any other
workaround to avoid above exception?

Could you please help. 




--
Sent from: http://struts.1045723.n5.nabble.com/Struts-User-f3426046.html

---------------------------------------------------------------------
To unsubscribe, e-mail: user-unsubscribe@struts.apache.org
For additional commands, e-mail: user-help@struts.apache.org


Mime
View raw message