struts-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Lukasz Lenart <lukaszlen...@apache.org>
Subject Re: S2.5.20 Illegal reflective access by ognl.OgnlRuntime
Date Fri, 25 Jan 2019 11:43:55 GMT
Hi Burton,

This probably is related to
https://issues.apache.org/jira/browse/WW-5004
https://issues.apache.org/jira/browse/WW-5006

and you can downgrade OGNL version to 3.1.18 or wait for 2.5.21
(should be ready soon)


Regards
-- 
Łukasz
+ 48 606 323 122 http://www.lenart.org.pl/

pt., 25 sty 2019 o 12:41 Burton Rhodes <burtonrhodes@gmail.com> napisał(a):
>
> After upgrading my application to JDK 11 and S2.5.20 I am receiving the
> following warning.  Curious if there is a bug or if my resolved version of
> ognl should be corrected in my pom.xml file
>
> WARNING: An illegal reflective access operation has occurred
> WARNING: Illegal reflective access by ognl.OgnlRuntime
> (file:/D:/m2/repository/ognl/ognl/3.1.21/ognl-3.1.21.jar) to method
> java.util.TreeMap$Entry.getKey()
> WARNING: Please consider reporting this to the maintainers of
> ognl.OgnlRuntime
> WARNING: Use --illegal-access=warn to enable warnings of further illegal
> reflective access operations
> WARNING: All illegal access operations will be denied in a future release
>
> Thanks!
> Burton

---------------------------------------------------------------------
To unsubscribe, e-mail: user-unsubscribe@struts.apache.org
For additional commands, e-mail: user-help@struts.apache.org


Mime
View raw message