subversion-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Ivan Zhakov (JIRA)" <j...@apache.org>
Subject [jira] [Updated] (SVN-2122) 'svn status -u' can crash with partial -N working copy
Date Sat, 17 Oct 2015 13:08:05 GMT

     [ https://issues.apache.org/jira/browse/SVN-2122?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Ivan Zhakov updated SVN-2122:
-----------------------------
    Description: 
Adeodato Simó <asp16@alu.ua.es> posted this report to dev@ today.  The message hasn't
shown up in the archives yet, but it's this one:
{quote}
From: Adeodato Simó <asp16@alu.ua.es>
To: dev@subversion.tigris.org
Subject:  crash when doing svn st -u (assertion failed)
Date: Fri, 12 Nov 2004 00:32:25 +0100
Message-ID: <20041111233225.GA23928@chistera.yi.org>
{quote}

The recipe is simple, and reproduces for me with svn 1.2 (dev build):
{noformat}
 $ svn co -N -r 213 svn://svn.debian.org/pkg-kde .
 A  README
 Checked out revision 213.
 
 $ svn up -r 213 scripts www
 [ List of scripts/* files.]
 Updated to revision 213.
 [ List of www/* files.]
 Updated to revision 213.
   
 $ svn st -u
    *      213   www/IGNORE-ME
    *      213   www
 svn: subversion/libsvn_wc/status.c:910: tweak_statushash:       \
    Assertion `repos_text_status == svn_wc_status_added' failed. \
    Aborted (core dumped)
{noformat}

At first, I thought this might be related to SteveKing's status crash bug report, at
  Original post:
{quote}
From: SteveKing <steveking@gmx.ch>
Subject:  crash when fetching status
Message-ID: <4187D596.6040205@gmx.ch>
Date: Tue, 02 Nov 2004 19:44:38 +0100
http://subversion.tigris.org/servlets/ReadMsg?list=dev&msgNo=82253
{quote}

   Whole thread:
     http://tinyurl.com/4tzqd

However, looking more closely now, I'm less optimistic that it's the same bug. The assertion
that's failing in this new report is one added in r6913, yet it's apparently not being triggered
in SteveKing's situation.  Investigating now.

  was:
{noformat:nopanel=true}
Adeodato Simó <asp16@alu.ua.es> posted this report to dev@ today.  The message
hasn't shown up in the archives yet, but it's this one:

   From: Adeodato Simó <asp16@alu.ua.es>
   To: dev@subversion.tigris.org
   Subject:  crash when doing svn st -u (assertion failed)
   Date: Fri, 12 Nov 2004 00:32:25 +0100
   Message-ID: <20041111233225.GA23928@chistera.yi.org>

The recipe is simple, and reproduces for me with svn 1.2 (dev build):

   $ svn co -N -r 213 svn://svn.debian.org/pkg-kde .
   A  README
   Checked out revision 213.
   
   $ svn up -r 213 scripts www
   [ List of scripts/* files.]
   Updated to revision 213.
   [ List of www/* files.]
   Updated to revision 213.
   
   $ svn st -u
      *      213   www/IGNORE-ME
      *      213   www
   svn: subversion/libsvn_wc/status.c:910: tweak_statushash:       \
      Assertion `repos_text_status == svn_wc_status_added' failed. \
      Aborted (core dumped)

At first, I thought this might be related to SteveKing's status crash bug report, at

   Original post:
     From: SteveKing <steveking@gmx.ch>
     Subject:  crash when fetching status
     Message-ID: <4187D596.6040205@gmx.ch>
     Date: Tue, 02 Nov 2004 19:44:38 +0100
     http://subversion.tigris.org/servlets/ReadMsg?list=dev&msgNo=82253

   Whole thread:
     http://tinyurl.com/4tzqd

However, looking more closely now, I'm less optimistic that it's the same bug. 
The assertion that's failing in this new report is one added in r6913, yet it's
apparently not being triggered in SteveKing's situation.  Investigating now.
{noformat}


> 'svn status -u' can crash with partial -N working copy
> ------------------------------------------------------
>
>                 Key: SVN-2122
>                 URL: https://issues.apache.org/jira/browse/SVN-2122
>             Project: Subversion
>          Issue Type: Bug
>          Components: libsvn_wc
>    Affects Versions: all
>            Reporter: Karl Fogel
>            Assignee: Ben Reser
>             Fix For: unscheduled
>
>
> Adeodato Simó <asp16@alu.ua.es> posted this report to dev@ today.  The message
hasn't shown up in the archives yet, but it's this one:
> {quote}
> From: Adeodato Simó <asp16@alu.ua.es>
> To: dev@subversion.tigris.org
> Subject:  crash when doing svn st -u (assertion failed)
> Date: Fri, 12 Nov 2004 00:32:25 +0100
> Message-ID: <20041111233225.GA23928@chistera.yi.org>
> {quote}
> The recipe is simple, and reproduces for me with svn 1.2 (dev build):
> {noformat}
>  $ svn co -N -r 213 svn://svn.debian.org/pkg-kde .
>  A  README
>  Checked out revision 213.
>  
>  $ svn up -r 213 scripts www
>  [ List of scripts/* files.]
>  Updated to revision 213.
>  [ List of www/* files.]
>  Updated to revision 213.
>    
>  $ svn st -u
>     *      213   www/IGNORE-ME
>     *      213   www
>  svn: subversion/libsvn_wc/status.c:910: tweak_statushash:       \
>     Assertion `repos_text_status == svn_wc_status_added' failed. \
>     Aborted (core dumped)
> {noformat}
> At first, I thought this might be related to SteveKing's status crash bug report, at
>   Original post:
> {quote}
> From: SteveKing <steveking@gmx.ch>
> Subject:  crash when fetching status
> Message-ID: <4187D596.6040205@gmx.ch>
> Date: Tue, 02 Nov 2004 19:44:38 +0100
> http://subversion.tigris.org/servlets/ReadMsg?list=dev&msgNo=82253
> {quote}
>    Whole thread:
>      http://tinyurl.com/4tzqd
> However, looking more closely now, I'm less optimistic that it's the same bug. The assertion
that's failing in this new report is one added in r6913, yet it's apparently not being triggered
in SteveKing's situation.  Investigating now.



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message