subversion-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Ivan Zhakov (JIRA)" <j...@apache.org>
Subject [jira] [Comment Edited] (SVN-2935) mod_dav_svn + Apache/mpm_worker don't play nice
Date Fri, 09 Oct 2015 22:27:05 GMT

    [ https://issues.apache.org/jira/browse/SVN-2935?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=14925494#comment-14925494
] 

Ivan Zhakov edited comment on SVN-2935 at 10/9/15 10:26 PM:
------------------------------------------------------------

See also issue SVN-4157.


was (Author: philipm):
{noformat:nopanel=true}
See also issue 4157.
{noformat}


> mod_dav_svn + Apache/mpm_worker don't play nice
> -----------------------------------------------
>
>                 Key: SVN-2935
>                 URL: https://issues.apache.org/jira/browse/SVN-2935
>             Project: Subversion
>          Issue Type: Bug
>          Components: mod_dav_svn
>    Affects Versions: 1.4.x
>         Environment: Linux
>            Reporter: Subversion Importer
>            Priority: Blocker
>             Fix For: unscheduled
>
>         Attachments: 1_svn-fix.patch
>
>
> {noformat:nopanel=true}
> I have seen reports of this in email, and experienced it myself, but I cannot
> find any bug report for this in the bug tracking system.
> The issue is that with mpm_worker, mod_dav_svn will cause the apache process it
> is in to core dump.  This only happens when the frequency of SVN requests
> increases (ie. occasional usage does not cause this - however when doing
> something like a repository diff scan (ie. repeated requests to get all diffs to
> build a diff database for something like a subversion front-end like FishEye)
> will trigger it every time).
> It has been previously reported here:
> http://svn.haxx.se/users/archive-2006-02/1317.shtml
> And is also listed as a bug on the apache issue tracker (though it is more
> likely a mod_dav_svn bug than an apache bug):
> http://issues.apache.org/bugzilla/show_bug.cgi?id=42262
> The latter link includes a stack trace (Thread 9 is interesting), but
> unfortunately I did not have subversion compiled with symbols at the time, I
> will re-run it and attach it here.
> {noformat}
> Original issue reported by *prez*



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message