subversion-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Ivan Zhakov (JIRA)" <j...@apache.org>
Subject [jira] [Comment Edited] (SVN-3084) apache memory leak with mod_deflate and mod_dav_svn
Date Sat, 17 Oct 2015 18:13:05 GMT

    [ https://issues.apache.org/jira/browse/SVN-3084?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=14926389#comment-14926389
] 

Ivan Zhakov edited comment on SVN-3084 at 10/17/15 6:12 PM:
------------------------------------------------------------

Minor correction to earlier comment: the Apache mod_deflate bug was fixed on trunk with http://svn.apache.org/r1103315
and this was released with Apache 2.4. This has not been backported to Apache 2.2.




was (Author: philipm):
{noformat:nopanel=true}
Minor correction to earlier comment: the Apache mod_deflate bug was fixed on
trunk with http://svn.apache.org/r1103315 and this was released with Apache 2.4.
This has not been backported to Apache 2.2.
{noformat}


> apache memory leak with  mod_deflate and mod_dav_svn
> ----------------------------------------------------
>
>                 Key: SVN-3084
>                 URL: https://issues.apache.org/jira/browse/SVN-3084
>             Project: Subversion
>          Issue Type: Bug
>          Components: mod_dav_svn
>    Affects Versions: 1.5.x
>            Reporter: Subversion Importer
>            Priority: Critical
>             Fix For: unscheduled
>
>
> {noformat:nopanel=true}
> I'm using
> windows server 2003 R2 SP1
> apache 2.2.6 (xampp http://www.apachefriends.org/en/xampp-windows.html )
> svn 1.4.5
> My problem is that the memory usage of the apache process is growing and growing.
> It starts with about 20MB and goes up to about 1.5 GB until there is no more
> memory and apache crashes.
> According to the response on
> http://subversion.tigris.org/servlets/ReadMsg?list=users&&msgNo=73162 I'm not
> the only one who's having this problem
> The memory usage only grows when I'm using a svn client.
> When I'm browsing the repository with firefox, everything is fine.
> {noformat}
> http://subversion.tigris.org/servlets/ReadMsg?list=users&&msgNo=73162
> Original issue reported by *schrei5*



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message