subversion-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Matthias St. Pierre (JIRA)" <j...@apache.org>
Subject [jira] [Comment Edited] (SVN-4677) svn up fails after a file is added, moved, deleted, replaced by a directory, and a file in the directory is deleted
Date Fri, 22 Dec 2017 23:23:00 GMT

    [ https://issues.apache.org/jira/browse/SVN-4677?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=16302092#comment-16302092
] 

Matthias St. Pierre edited comment on SVN-4677 at 12/22/17 11:22 PM:
---------------------------------------------------------------------

The symptom seems to be different depending on whether the repository is accessed locally
via the file:// protocol or remotely via https://. Is this a known issue? Seems like the malformed
XML is a consequence of this error, but maybe there is an additional bug?

After creating the repository {{/srv/svn/repo}} using the script from this ticket, I get

*locally*

{code}
# svn diff -c 6 file:///srv/svn/repo
svn: E160016: Failure opening '/b/fa/fb'
svn: E160016: '/b/fa' is not a directory in filesystem '4e3a0f0d-74f0-4cac-a204-9ce6e9944b0a
{code}

*remote*

{code}
~$ svn diff -c 6  https://svn.local/svn/repo
svn: E175009: The XML response contains invalid XML
svn: E130003: Malformed XML: no element found
{code}




was (Author: mspncp):
The symptom seems to be different depending on whether the repository is accessed via the
file:// protocol or via https://. Is this a known issue? Seems like the malformed XML is a
consequence of this error, but maybe there is an additional bug?

After creating the repository {{/srv/svn/repo}} using the script from this ticket, I get

*locally*

{code}
# svn diff -c 6 file:///srv/svn/repo
svn: E160016: Failure opening '/b/fa/fb'
svn: E160016: '/b/fa' is not a directory in filesystem '4e3a0f0d-74f0-4cac-a204-9ce6e9944b0a
{code}

*remote*

{code}
~$ svn diff -c 6  https://svn.local/svn/repo
svn: E175009: The XML response contains invalid XML
svn: E130003: Malformed XML: no element found
{code}



> svn up fails after a file is added, moved, deleted, replaced by a directory, and a file
in the directory is deleted
> -------------------------------------------------------------------------------------------------------------------
>
>                 Key: SVN-4677
>                 URL: https://issues.apache.org/jira/browse/SVN-4677
>             Project: Subversion
>          Issue Type: Bug
>          Components: libsvn_fs_fs
>    Affects Versions: 1.9.x, trunk
>            Reporter: Orivej Desh
>            Assignee: Stefan Fuhrmann
>             Fix For: 1.9.8, 1.10.0
>
>
> This bug was introduced in http://svn.apache.org/viewvc?view=revision&revision=1586953
, is present in all releases since 1.9.0, and can be fixed by reverting that commit. The following
script reproduces it:
> {code}
> rm -rf repo repo1 repo2
> svnadmin create repo
> svn co "file://$(pwd)/repo" repo1
> cd repo1
> mkdir a
> svn add a
> svn commit -m 1
> svn up
> echo fa > a/fa
> svn add a/fa
> svn commit -m 2
> svn up
> svn mv a b
> svn commit -m 3
> svn up
> svn rm b/fa
> svn commit -m 4
> svn up
> mkdir b/fa/
> touch b/fa/fb
> svn add b/fa
> svn commit -m 5
> svn up
> svn rm b/fa/fb
> svn commit -m 6
> svn up
> cd ..
> svn co "file://$(pwd)/repo" repo2 -r5
> cd repo2
> svn up
> {code}
> {{svn up}} fails with
> {code}
> Updating '.':
> svn: E160016: Failure opening '/b/fa/fb'
> svn: E160016: '/b/fa' is not a directory in filesystem '1d2dc934-16b4-452c-a607-a6080764124e'
> {code}



--
This message was sent by Atlassian JIRA
(v6.4.14#64029)

Mime
View raw message