subversion-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Stefan Sperling <>
Subject Re: svnserve and ldap status ?
Date Tue, 23 Mar 2010 16:11:37 GMT
On Tue, Mar 23, 2010 at 10:39:56AM -0500, Alec Kloss wrote:
> On 2010-03-23 15:22, Stefan Sperling wrote:
> > It's a bit unfortunate that most of our developers lack expertise in
> > external authentication mechanisms Subversion is hooked up to.
> > The reason is probably that our developers tend to focus on version control
> > problems rather than system administration and security. There are so many
> > problems to solve in version control already that patches like this get
> > overlooked (or put aside for "some time later") easily.
> > 
> > It would help to have a developer focused on authorisation mechanisms,
> > the ones inside of Subversion as well as integration with external ones.
> > Right now we have no such developer.
> Stefan: I'm not trying to be snyde, but I've tried getting the SASL
> cross-realm support in svnserve fixed in the past and not had
> much success.  It's a little demotivational.

Hi Alec,

I remember your patch. It looked pretty simple and OK to me, but
I didn't feel confident enough about my own understanding of what
the patch really does.
I understand that not receiving much response to your patch won't exactly
encourage you to contribute further, so I will try to take a look at it again.

I'd like to be able to test it though. First I'll need to find time to read
about SASL and realms (ie. figure out what we're really talking about).
If you can speed this up by giving me a hint as to what to read, that would
be great. If you can also help me with setting up a proper test environment that
would be even nicer! I will try to get something set up with the instructions
you gave Remi. If I run into problems I'll get back to you.

Oh, and if one of you feels like doing a proper write up, a patch to the
svnbook which documents how to set this up would be most lovely.

If your patch gets lost again please feel free to keep pinging me about it.
I will eventually get to it. If the patch is not already in the issue
tracker please feel free to add it there, to an issue with milestone 1.7.0.


View raw message