subversion-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Ryan Schmidt <subversion-20...@ryandesign.com>
Subject Re: URL does not exist
Date Mon, 01 Mar 2010 13:37:52 GMT

On Mar 1, 2010, at 07:32, John McMorris wrote:

> -Not a working copy, on the Repository, I was going to do a first import after creating
a directory for it.
> -I created and deleted using RapidSVN on a MAC
> -svn list svn://localhost/SVN_REP
> 
> APIs/
> Installs/
> Directory%20Name/
> Client/
> docs/
> 
> -RapidSVN produces this error:
> 
> "Error while performing action: URL 'Directory Name' does not exist"

I don't know anything about RapidSVN, but it sounds like the directory name in the repository
might not be "Directory Name" but might in fact be "Directory%20Name". I don't know how that
would have come to pass if you didn't mean for that to occur, but perhaps RapidSVN does not
properly handle items whose names contain spaces.


> -svn delete svn://localhost/SVN_REP/Directory%20Name       puts me in Joe's Editor with
the following:
> 
> --This line, and those below, will be ignored--
> 
> D    svn://localhost/SVN_REP/Directory%20Name

And what happens when you enter a commit message, save, and close? Does the commit succeed
or do you get the error that "Directory Name" does not exist? If so, try:

svn delete svn://localhost/SVN_REP/Directory%2520Name

(where "%25" is the percent-encoding for the percent sign).



Mime
View raw message