subversion-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From James Thomson ...@james-thomson.net>
Subject Re: Retrieval of mergeinfo unsupported (even after repo upgrade)
Date Wed, 24 Mar 2010 14:59:10 GMT
On 24/03/2010 14:37, Mark Phippard wrote:
> On Wed, Mar 24, 2010 at 10:39 AM, James Thomson<jt@james-thomson.net>  wrote:
>    
>> On 24/03/2010 14:31, Mark Phippard wrote:
>>      
>>> On Wed, Mar 24, 2010 at 10:26 AM, James Thomson<jt@james-thomson.net>
>>>   wrote:
>>>
>>>        
>>>> Now I try and do a merge using the Subversion client in Debian:
>>>>
>>>>     svn mergeinfo https://mysvn/repo .
>>>>
>>>> and I get the following error:
>>>>
>>>>     svn: Retrieval of mergeinfo unsupported by '.'
>>>>
>>>> I get the same error message whether I'm using the Debian shell on the
>>>> same
>>>> server or if I'm connecting via TortoiseSVN and a Windows box.
>>>>
>>>> If I browse to the repository using my web browser, the version number at
>>>> the bottom reads:
>>>>
>>>>     Powered by Subversion version 1.4.2 (r22196).
>>>>
>>>>          
>>> I think your answer is ultimately right here ^^
>>>
>>> Your mod_dav_svn is not SVN 1.5.  I cannot tell you why.  Did you
>>> restart Apache after upgrading packages?
>>>
>>>
>>>        
>> Yes, I've restarted apache using "/etc/init.d/apache2 restart" several
>> times. No joy.
>>
>> I'm assuming that the mod_dav_svn is something that the backport package
>> should update, but hasn't. Does this sound reasonable?
>>      
> I believe it comes in its own Debian package.  Did you update it too,
> or just the base SVN package?
>
>    

Yep, that did the trick! Thanks very very much guys!

James.

Mime
View raw message