subversion-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Gary M. Gere" <Gary.G...@Sun.COM>
Subject svn merge issues after upgrading server from 1.4.3 to 1.6.6 - unexpected property changes (deleted svn:mergeinfo)
Date Thu, 25 Mar 2010 18:23:24 GMT
-All,

This is my first time posting to this alias; I apologize in advance for 
any protocol mistakes, but we are in a serious situation and I need to 
get some guidance/help as soon as possible.

I tried searching through the issues database but could not find 
anything that appeared to be the issue we are encountering, so I am 
posting this request.

We recently upgraded our subversion server software and are having major 
problems with merging after moving the subversion server from 1.4.2 to 
1.6.6. I am asking the user community for any help they can give us.

The details of the prior and current software versions are detailed at 
the end of this email.

The problem we are having is with 'svn merge' with a workspace that was 
checked out using the subversion 1.4.2 server:

   - cd <destination-branch-directory>
   - svn merge -r revision1:revision2 SOURCE_SVN_URL .

This results in many unrelated files are having their properties change, 
and many unrelated files being included in the merge. It makes it very 
difficult to verify that the merge was successful when many unrelated 
files are included.

A small example:

An attempt to merge one change from sw1.0 to sw2.0 branch.
A folder called Docs contains files that have not been changed.
An svn diff produces the following:

    % cd /data/source/branches/sw2.0
    % svn stat -q Docs/
      M      Docs/WDS-RIS-Blueprint.odt
      M      Docs/WDS-RIS-Script-Usage.odt

    % svn diff Docs/

    Property changes on: Docs/WDS-RIS-Blueprint.odt
    ___________________________________________________________________
    Deleted: svn:mergeinfo


    Property changes on: Docs/WDS-RIS-Script-Usage.odt
    ___________________________________________________________________
    Deleted: svn:mergeinfo

A mix of subversion clients have been in use, including 1.4, 1.5 and 1.6 
based clients. Those have not changed, and this behavior occurs even 
using a 1.6.9 client.

Can anyone provide any guidance, clues, pointers, etc. to what we need 
to do to address this issue??

Thank you very much in advance,
-GmG

Prior to last Monday 22-Mar-2010, we had a system running the following:
   - RHEL-5.3 64-bit (Linux 2.6.18-128.1.6.el5 #1 SMP Tue Mar 24 
12:05:57 EDT 2009 x86_64)
   - subversion 1.4.2 (r22196, Sep 1 2008) (subversion-1.4.2-4.el5, 
subversion-devel-1.4.2-4.el5, subversion-javahl-1.4.2-4.el5, 
subversion-perl-1.4.2-4.el5, subversion-ruby-1.4.2-4.el5)
   - openssl OpenSSL 0.9.8e-fips-rhel5 01 Jul 2008 
(mod_ssl-2.2.3-22.el5, openssl097a-0.9.7a-9.el5_2.1, 
openssl-0.9.8e-7.el5, openssl-devel-0.9.8e-7.el5)
   - httpd Apache/2.2.3 (Nov 12 2008) (httpd-2.2.3-22.el5, 
httpd-devel-2.2.3-22.el5, system-config-httpd-1.3.3.3-1.el5)
   - Berkeley DB 4.3.29 (db4-4.3.29-9.fc6, db4-devel-4.3.29-9.fc6)

The subversion repository is format "3"

We upgraded the system to:
   - RHEL-5.4 64-bit (Linux 2.6.18-164.el5 #1 SMP Thu Sep 3 04:15:13 EDT 
2009 x86_64)
   - subversion 1.6.6 (r40053, Oct 22 2009) 
(subversion-1.6.6-0.1.el5.rf, subversion-devel-1.6.6-0.1.el5.rf, 
subversion-perl-1.6.6-0.1.el5.rf)
   - openssl OpenSSL 0.9.8e-fips-rhel5 01 Jul 2008 
(Mod_ssl-2.2.3-31.0.1.el5, openssl-0.9.8e-12.el5_4.1, 
openssl-devel-0.9.8e-12.el5_4.1, openssl-perl-0.9.8e-12.el5_4.1)
   - httpd Apache/2.2.3 (Sep 3 2009) (httpd-2.2.3-31.0.1.el5, 
httpd-manual-2.2.3-31.0.1.el5, system-config-httpd-1.3.3.1-1.el5.0.1)
   - Berkeley DB 4.3.29 (db4-4.3.29-10.el5, db4-devel-4.3.29-10.el5)

The subversion repository was not upgraded and is still in format "3".





Mime
View raw message