subversion-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Thomas O'Brien" <>
Subject Could not resolve path ... for history error
Date Thu, 25 Mar 2010 21:13:11 GMT
Hi all,

I recently ran into a problem retrieving revision information. The errors
for retrieving revision
history (using svn blame) happened after a recent move of a directory
containing Java
files. After the move I started to receive errors when using 'svn blame' so
I tried to do a
reverse merge. When using 'svn blame' continued to have errors I tried using
svn delete to
remove the directory and svn copy with the revision number before the
directory move to
restore the directory to the revision before the move. Now when I try to use
svn blame I am
receiving "Could not resolve path ... for history".

The exact line I am using is:
svn blame

which returned:
svn: Could not resolve path
/trunk/src/ca/sqlpower/architect/ for history

Running the command:
svn cat

returned the file as it existed before the directory move.

I have tried searching the web and the mailing list for users with a similar
problem but have
found none. From the "Version Control with Subversion" section on
resurrecting deleted items
using 'svn delete' on the directory then 'svn copy' on the revision before
the change should link
the new directory and files with the ones before the move and remove this
error but it did not.

Is there a way to restore my directory so the revision history of the files
are linked with the originals?

The full set of changes were as follows:
For reference:
svn: version 1.6.3
Eclipse: version 3.4.1
Subclipse: version 1.6.3

Before any changes I was on r3393.

I started with moving the directory and all subdirectories and files at
trunk/src/ca to
trunk/src/main/java/ca using Eclipse and Subclipse.
The log:
svn log -v -r 3394

r3394 | | 2010-03-24 17:07:56 -0400 (Wed, 24 Mar
2010) | 3 lines
Changed paths:
   D /trunk/src/ca
   A /trunk/src/main
   A /trunk/src/main/java
   A /trunk/src/main/java/ca (from /trunk/src/ca:3393)
This appears that the folder was moved correctly and the history of
is linked to /trunk/src/ca as expected.

Next I tried to view revision information:
svn blame

svn: Could not resolve path /trunk/src/ca/ for history
I noticed the path at this point was wrong. The file
is located at

Verifying revision information:
svn blame

1600     fuerth /*
  2099  * Copyright (c) 2008, SQL Power Group Inc.
  2099  *
  2099  * This f....
Since the revision before my commit caused the error I decided it would be
best to
reverse the change.

The first step I took to try and reverse the change was I went to Eclipse
and did a reverse
merge from r3394 to r3393. This reversed the file move but retrieving
revision information
was still failing:
svn blame

svn: Could not resolve path
/trunk/src/ca/sqlpower/architect/ for history
The path to the file was now correct but the path still could not be

Finally, I decided to try and remove the entire directory and copy
everything from r3393,
before the directory change.
I tried:
svn delete -m "removing all of src to check it back in to fix history."
followed by:
svn copy

However, this still resulted in:
svn blame

svn: Could not resolve path
/trunk/src/ca/sqlpower/architect/ for history

Any help in restoring my revision history would be greatly appreciated.



View raw message