subversion-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Petyo Ivanov <>
Subject Unicode support in ruby bindings checkout
Date Tue, 23 Mar 2010 11:32:20 GMT

I have run into an issue with the ruby bindings, when dealing with
filenames containing unicode symbols.

Setup is CentOS:

[root@centos ~]# ruby -v
ruby 1.8.6 (2008-08-11 patchlevel 287) [x86_64-linux]
[root@centos ~]# svn --version
svn, version 1.6.6 (r40053)
   compiled Jan  8 2010, 18:32:29
[root@centos ~]#

I tried various installations, both from source and from packages, all
leading to the same result.

The test script is this:

When I execute it, I get the following result:

[root@centos ~]# ruby test-checkout.rb
`svn_client_checkout3':  (Svn::Error::SvnError)

subversion/libsvn_subr/utf.c:507: 22: m?\195?\164dchen.csv
	from /usr/lib64/ruby/site_ruby/1.8/x86_64-linux/svn/util.rb:86:in `checkout3'
	from /usr/lib64/ruby/site_ruby/1.8/x86_64-linux/svn/client.rb:124:in `checkout'
	from test-checkout.rb:21

(the file contains a file named trunk/m├Ądchen.csv)

what is more interesting here, if i do

irb, and

require 'test-checkout'

The script passes without a problem.

Any hints on the meaning of the error:

subversion/libsvn_subr/utf.c:507: 22: m?\195?\164dchen.csv

Would be greatly appreciated. Maybe an environment variable? The same
test passes without a problem on OS X.

View raw message