subversion-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Stefan Sperling <s...@elego.de>
Subject Re: subversion on dns323
Date Tue, 06 Jul 2010 09:10:03 GMT
On Tue, Jul 06, 2010 at 06:46:05AM +0200, Ronald Geisler wrote:
> 2010/7/5 Stefan Sperling <stsp@elego.de>:
> > On Mon, Jul 05, 2010 at 08:10:35PM +0200, Ronald Geisler wrote:
> >> root@BetaNAS:/ffp/src/subversion-1.6.12# make check-swig-py
> >> cd /ffp/src/subversion-1.6.12/subversion/bindings/swig/python; \
> >>           /ffp/bin/python
> >> /ffp/src/subversion-1.6.12/subversion/bindings/swig/python/tests/run_all.py
> >> /ffp/bin/python: can't resolve symbol 'apr_uuid_parse'
> >> make: *** [check-swig-py] Error 1
> >>
> >> can you help me?
> >
> > My guess is that you need to run:
> >  export LD_LIBRARY_PATH=/ffp/lib
> > before running the python tests.
> >
> > Stefan
> >
> 
> i add /ffp/lib to LD_LIBRARY_PATH and LD_RUN_PATH but i get the same error.

You definitely have a problem with shared libraries.
I suspect that when python tries to load the svn bindings,
the wrong APR library gets loaded (APR is needed by the svn libraries).
Most likely it is loading a different APR library than you compiled svn with.

Do you have other APR libraries on your system somewhere?
What happens if you move them to a temporary directory temporarily?

Maybe you can spot the problem by running with export LD_DEBUG=all
and search the output for loading of apr libraries?

Stefan

Mime
View raw message