subversion-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Nico Kadel-Garcia <nka...@gmail.com>
Subject Re: SVN Apache Installation
Date Thu, 08 Jul 2010 12:14:37 GMT
On Wed, Jul 7, 2010 at 4:40 PM, Ryan Schmidt
<subversion-2010b@ryandesign.com> wrote:
>
> On Jul 7, 2010, at 11:49, Andy Levy wrote:
>
>> The Subversion modules for Apache require Apache 2.2.x, so you will
>> need to upgrade or install 2.2 in parallel with 2.0.63.
>
> Did that change recently? I know Subversion used to compile just fine with Apache 2.0.x
or 2.2.x and that there were binaries posted for both. But I can't find those now.

Compiling Subversion "just fine" on legacy operating systems is
painful, inlcluding RHEL 4 (which contained httpd-2.0.63). The
dependencies on more recent versions of Python, neon, and SQlite are
awkward to mange.

If possible, update to RHEL 5 or CentOS 5 and grab the RPMforge
release of subversion-1.6.12. You'll save yourself a lot of pain: I
found backporting to RHEL 4 to be a big problem and gave it up as too
tough to provide a completely workable install, especially for x86_64,
years ago.

Mime
View raw message