subversion-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Ameet Nanda <ameet.na...@gmail.com>
Subject Re: Problem with commit
Date Fri, 23 Jul 2010 08:08:41 GMT
Nevamind got it fixed. I changed the subversion.conf from

<LimitExcept GET PROPFIND OPTIONS REPORT>

to

<LimitExcept GET PROPFIND CHECKOUT PROPPATCH PUT MERGE DELETE MKACTIVITY
OPTIONS REPORT>

and got it working.

-Ameet

On Fri, Jul 23, 2010 at 12:46 AM, Daniel Shahaf <d.s@daniel.shahaf.name>wrote:

> Ameet Nanda wrote on Thu, Jul 22, 2010 at 17:23:54 -0700:
> > Hi,
> >
> > I set up SVN with apache and everything seems to be running fine.
> However,
> > when I try to commit, it prompts me for a password, and once I supply the
> > password, it gives me the following error:
> >
> > svn: Commit failed (details follow):
> > svn: Server sent unexpected return value (500 Internal Server Error) in
>
> What does the httpd error log say?
>
> > response to MKACTIVITY request for
> > '/repos/testrep/!svn/act/b5cf039a-95ed-11df-a9f1-a38cb1af4ec0'
> >
> > I am running SLES 11 and this is my subversion.conf file located at
> > /etc/apache2/conf.d/subversion.conf :
> >
> > *<IfModule mod_dav_svn.c>
> > <location /repos>
> >         DAV svn
> >         SVNParentPath /srv/svn/repos/
> >         SVNListParentPath On
> >         <LimitExcept GET PROPFIND OPTIONS REPORT>
> >                 AuthType Basic
> >                 AuthName "Commiting to repository requires a password"
> >                 AuthUserFile /srv/svn/user_access/svn_passwdfile
> >                 Require valid-user
> >         </LimitExcept>
> > </location>*
> >
> >
> > What am I doing wrong here ?
> >
> > Thanks,
> > Ameet
>

Mime
View raw message